Date   

[meta-oe] [PATCH] ctags: upgrade 5.9.20210905.0 -> 5.9.20211114.0

wangmy
 

Make: fill "end:" fields

Signed-off-by: Wang Mingyu <wangmy@...>
---
.../ctags/{ctags_5.9.20210905.0.bb => ctags_5.9.20211114.0.bb} | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
rename meta-oe/recipes-devtools/ctags/{ctags_5.9.20210905.0.bb => ctags_5.9.20211114.0.bb} (95%)

diff --git a/meta-oe/recipes-devtools/ctags/ctags_5.9.20210905.0.bb b/meta-oe/recipes-devtools/ctags/ctags_5.9.20211114.0.bb
similarity index 95%
rename from meta-oe/recipes-devtools/ctags/ctags_5.9.20210905.0.bb
rename to meta-oe/recipes-devtools/ctags/ctags_5.9.20211114.0.bb
index 4cc1c12b65..cde7c7a0ef 100644
--- a/meta-oe/recipes-devtools/ctags/ctags_5.9.20210905.0.bb
+++ b/meta-oe/recipes-devtools/ctags/ctags_5.9.20211114.0.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"

inherit autotools-brokensep pkgconfig manpages

-SRCREV = "ca81123303640582358ce7b8a4e466615950a1f7"
+SRCREV = "a668cb155609d5a322963e1ed9a0c0147c8be597"
SRC_URI = "git://github.com/universal-ctags/ctags;branch=master;protocol=https"

S = "${WORKDIR}/git"
--
2.25.1


Re: [meta-python][PATCH 1/5] python3-cchardet: Add recipe

Khem Raj
 

Can you also add the new recipes to apropriate test packagegroups in meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb

On 11/15/21 10:56 AM, Leon Anavi wrote:
Universal character encoding detector, release 2.1.7:
- support Python 3.9
- drop support for Python 3.5
Signed-off-by: Leon Anavi <leon.anavi@...>
---
.../recipes-devtools/python/python3-cchardet_2.1.7.bb | 8 ++++++++
1 file changed, 8 insertions(+)
create mode 100644 meta-python/recipes-devtools/python/python3-cchardet_2.1.7.bb
diff --git a/meta-python/recipes-devtools/python/python3-cchardet_2.1.7.bb b/meta-python/recipes-devtools/python/python3-cchardet_2.1.7.bb
new file mode 100644
index 000000000..ebd8130ab
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cchardet_2.1.7.bb
@@ -0,0 +1,8 @@
+SUMMARY = "Universal character encoding detector"
+HOMEPAGE = "https://github.com/PyYoshi/cChardet"
+LICENSE = "MPLv1.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6ecda54f6f525388d71d6b3cd92f7474"
+
+SRC_URI[sha256sum] = "c428b6336545053c2589f6caf24ea32276c6664cb86db817e03a94c60afa0eaf"
+
+inherit pypi setuptools3


[meta-python][PATCH 1/5] python3-cchardet: Add recipe

Leon Anavi
 

Universal character encoding detector, release 2.1.7:

- support Python 3.9
- drop support for Python 3.5

Signed-off-by: Leon Anavi <leon.anavi@...>
---
.../recipes-devtools/python/python3-cchardet_2.1.7.bb | 8 ++++++++
1 file changed, 8 insertions(+)
create mode 100644 meta-python/recipes-devtools/python/python3-cchardet_2.1.7.bb

diff --git a/meta-python/recipes-devtools/python/python3-cchardet_2.1.7.bb b/meta-python/recipes-devtools/python/python3-cchardet_2.1.7.bb
new file mode 100644
index 000000000..ebd8130ab
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cchardet_2.1.7.bb
@@ -0,0 +1,8 @@
+SUMMARY = "Universal character encoding detector"
+HOMEPAGE = "https://github.com/PyYoshi/cChardet"
+LICENSE = "MPLv1.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6ecda54f6f525388d71d6b3cd92f7474"
+
+SRC_URI[sha256sum] = "c428b6336545053c2589f6caf24ea32276c6664cb86db817e03a94c60afa0eaf"
+
+inherit pypi setuptools3
--
2.20.1


[meta-python][PATCH 5/5] python3-aiohttp: Upgrade 3.8.0 -> 3.8.1

Leon Anavi
 

Upgrade to release 3.8.1:

- Fix the error in handling the return value of getaddrinfo.
getaddrinfo will return an (int, bytes) tuple, if CPython could
not handle the address family. It will cause a index out of
range error in aiohttp. For example, if user compile CPython
with --disable-ipv6 option but his system enable the ipv6.
- Do not install "examples" as a top-level package.
- Restored ability to connect IPv6-only host.
- Remove Signal from __all__, replace aiohttp.Signal with
aiosignal.Signal in docs
- Made chunked encoding HTTP header check stricter

Signed-off-by: Leon Anavi <leon.anavi@...>
---
.../{python3-aiohttp_3.8.0.bb => python3-aiohttp_3.8.1.bb} | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
rename meta-python/recipes-devtools/python/{python3-aiohttp_3.8.0.bb => python3-aiohttp_3.8.1.bb} (78%)

diff --git a/meta-python/recipes-devtools/python/python3-aiohttp_3.8.0.bb b/meta-python/recipes-devtools/python/python3-aiohttp_3.8.1.bb
similarity index 78%
rename from meta-python/recipes-devtools/python/python3-aiohttp_3.8.0.bb
rename to meta-python/recipes-devtools/python/python3-aiohttp_3.8.1.bb
index 710f8f4ce..1d8434e3c 100644
--- a/meta-python/recipes-devtools/python/python3-aiohttp_3.8.0.bb
+++ b/meta-python/recipes-devtools/python/python3-aiohttp_3.8.1.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "https://github.com/aio-libs/aiohttp"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8074d6c6e217873b2a018a4522243ea3"

-SRC_URI[sha256sum] = "d3b19d8d183bcfd68b25beebab8dc3308282fe2ca3d6ea3cb4cd101b3c279f8d"
+SRC_URI[sha256sum] = "fc5471e1a54de15ef71c1bc6ebe80d4dc681ea600e68bfd1cbce40427f0b7578"

PYPI_PACKAGE = "aiohttp"
inherit setuptools3 pypi
@@ -20,4 +20,7 @@ RDEPENDS:${PN} = "\
${PYTHON_PN}-netserver \
${PYTHON_PN}-typing-extensions \
${PYTHON_PN}-yarl \
+ ${PYTHON_PN}-cchardet \
+ ${PYTHON_PN}-charset-normalizer \
+ ${PYTHON_PN}-aiosignal \
"
--
2.20.1


[meta-python][PATCH 4/5] python3-aiosignal: Add recipe

Leon Anavi
 

A list of registered asynchronous callbacks. Version 1.2.0:

- Added support for Python 3.10
- Mark aiosignal as Python3-only package

Signed-off-by: Leon Anavi <leon.anavi@...>
---
.../python/python3-aiosignal_1.2.0.bb | 12 ++++++++++++
1 file changed, 12 insertions(+)
create mode 100644 meta-python/recipes-devtools/python/python3-aiosignal_1.2.0.bb

diff --git a/meta-python/recipes-devtools/python/python3-aiosignal_1.2.0.bb b/meta-python/recipes-devtools/python/python3-aiosignal_1.2.0.bb
new file mode 100644
index 000000000..601ac8f45
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aiosignal_1.2.0.bb
@@ -0,0 +1,12 @@
+SUMMARY = "A list of registered asynchronous callbacks"
+HOMEPAGE = "https://github.com/aio-libs/aiosignal"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=cf056e8e7a0a5477451af18b7b5aa98c"
+
+SRC_URI[sha256sum] = "78ed67db6c7b7ced4f98e495e572106d5c432a93e1ddd1bf475e1dc05f5b7df2"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} = "\
+ ${PYTHON_PN}-frozenlist \
+"
--
2.20.1


[meta-python][PATCH 3/5] python3-frozenlist: Add recipe

Leon Anavi
 

A list-like structure which implements
collections.abc.MutableSequence, and which can be made immutable.
Version 1.2.0:

- FrozenList now supports being used as a generic type as per PEP
585, e.g. frozen_int_list: FrozenList[int] (requires Python 3.9
or newer)
- Added support for Python 3.10
- Started shipping platform-specific wheels with the musl tag
targeting typical Alpine Linux runtimes
- Started shipping platform-specific arm64 wheels for Apple Silicon

Signed-off-by: Leon Anavi <leon.anavi@...>
---
.../recipes-devtools/python/python3-frozenlist_1.2.0.bb | 8 ++++++++
1 file changed, 8 insertions(+)
create mode 100644 meta-python/recipes-devtools/python/python3-frozenlist_1.2.0.bb

diff --git a/meta-python/recipes-devtools/python/python3-frozenlist_1.2.0.bb b/meta-python/recipes-devtools/python/python3-frozenlist_1.2.0.bb
new file mode 100644
index 000000000..b56e2e5e6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-frozenlist_1.2.0.bb
@@ -0,0 +1,8 @@
+SUMMARY = "A list-like structure which implements collections.abc.MutableSequence, and which can be made immutable."
+HOMEPAGE = "https://github.com/aio-libs/frozenlist"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=cf056e8e7a0a5477451af18b7b5aa98c"
+
+SRC_URI[sha256sum] = "68201be60ac56aff972dc18085800b6ee07973c49103a8aba669dee3d71079de"
+
+inherit pypi setuptools3
--
2.20.1


[meta-python][PATCH 2/5] python3-charset-normalizer: Add recipe

Leon Anavi
 

Package for encoding & language detection. Charset detection.
Version 2.0.7:

- Add support for Kazakh (Cyrillic) language detection
- Further improve inferring the language from a given code page
(single-byte)
- Remove redundant logging entry about detected language(s)
- Trying to leverage PEP263 when PEP3120 is not supported
- Refactoring for potential performance improvements in loops
- Various detection improvement (MD+CD)
- Fix a minor inconsistency between Python 3.5 and other versions
regarding language detection

Signed-off-by: Leon Anavi <leon.anavi@...>
---
.../python/python3-charset-normalizer_2.0.7.bb | 8 ++++++++
1 file changed, 8 insertions(+)
create mode 100644 meta-python/recipes-devtools/python/python3-charset-normalizer_2.0.7.bb

diff --git a/meta-python/recipes-devtools/python/python3-charset-normalizer_2.0.7.bb b/meta-python/recipes-devtools/python/python3-charset-normalizer_2.0.7.bb
new file mode 100644
index 000000000..7db106398
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-charset-normalizer_2.0.7.bb
@@ -0,0 +1,8 @@
+SUMMARY = "The Real First Universal Charset Detector. Open, modern and actively maintained alternative to Chardet."
+HOMEPAGE = "https://github.com/ousret/charset_normalizer"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0974a390827087287db39928f7c524b5"
+
+SRC_URI[sha256sum] = "e019de665e2bcf9c2b64e2e5aa025fa991da8720daa3c1138cadd2fd1856aed0"
+
+inherit pypi setuptools3
--
2.20.1


[meta-python][PATCH] python3-email-validator: new package

Bartosz Golaszewski
 

Signed-off-by: Bartosz Golaszewski <brgl@...>
---
.../packagegroups/packagegroup-meta-python.bb | 1 +
.../python/python3-email-validator_1.1.3.bb | 13 +++++++++++++
2 files changed, 14 insertions(+)
create mode 100644 meta-python/recipes-devtools/python/python3-email-validator_1.1.3.bb

diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index 477215118..be0786f60 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -113,6 +113,7 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-dynamic-dispatch \
python3-ecdsa \
python3-editor \
+ python3-email-validator \
python3-engineio \
python3-et-xmlfile \
python3-evdev \
diff --git a/meta-python/recipes-devtools/python/python3-email-validator_1.1.3.bb b/meta-python/recipes-devtools/python/python3-email-validator_1.1.3.bb
new file mode 100644
index 000000000..b81e39a15
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-email-validator_1.1.3.bb
@@ -0,0 +1,13 @@
+SUMMARY = "A robust email address syntax and deliverability validation library."
+SECTION = "devel/python"
+LICENSE = "CC0-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=65d3616852dbf7b1a6d4b53b00626032"
+
+SRC_URI[md5sum] = "25582cf3d415c7fdd44b980a095e0d53"
+SRC_URI[sha256sum] = "aa237a65f6f4da067119b7df3f13e89c25c051327b2b5b66dc075f33d62480d7"
+
+PYPI_PACKAGE = "email_validator"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "python3-dnspython python3-idna"
--
2.25.1


[meta-oe][PATCH] Revert "libgusb: Use the correct args to disable vala support"

Martin Jansa
 

This reverts commit cb1968b5410fa415f5c6c70264ce83c4112b6d4d.

There is already vapi PACKAGECONFIG added in:
https://git.openembedded.org/meta-openembedded/commit/?id=8e816f6fd17ae4142e67b2224ef88dae97435a1c
which resolves this.

Signed-off-by: Martin Jansa <Martin.Jansa@...>
---
meta-oe/recipes-support/libgusb/libgusb_0.3.8.bb | 2 --
1 file changed, 2 deletions(-)

diff --git a/meta-oe/recipes-support/libgusb/libgusb_0.3.8.bb b/meta-oe/recipes-support/libgusb/libgusb_0.3.8.bb
index bde57e9ccb..51e7349043 100644
--- a/meta-oe/recipes-support/libgusb/libgusb_0.3.8.bb
+++ b/meta-oe/recipes-support/libgusb/libgusb_0.3.8.bb
@@ -12,5 +12,3 @@ PACKAGECONFIG[vapi] = "-Dvapi=true,-Dvapi=false"
SRC_URI = "git://github.com/hughsie/libgusb.git;branch=main;protocol=https"
SRCREV = "db9edbd8b45662d551194a0985173732f8f557a5"
S = "${WORKDIR}/git"
-
-PACKAGECONFIG[vala] = "-Dvapi=true,-Dvapi=false"
--
2.32.0


Re: [meta-oe][PATCH 2/2] php: Build minilua for build host

Claude Bing
 

Our solution is to convert the $(CC) to $(HOSTCC) which is then passed
via environment.

Essentially that is the same as having the php-native package build
minilua, correct? We are still working on your suggestion to compile
minilua in a style similar to
meta-oe/recipes-support/espeak/espeak_1.48.04.bb, but first we are
upgrading our environment to the honister branch (override syntax changes).

On 11/13/21 8:07 PM, Khem Raj wrote:
see https://bugs.php.net/bug.php?id=80717&edit=1

Signed-off-by: Khem Raj <raj.khem@...>
---
...1-opcache-jit-use-minilua-in-sysroot.patch | 29 -------------------
...10-Fix-opcache-jit-minilua-compiling.patch | 20 +++++++++++++
meta-oe/recipes-devtools/php/php_8.0.12.bb | 8 ++---
3 files changed, 22 insertions(+), 35 deletions(-)
delete mode 100644 meta-oe/recipes-devtools/php/php/0011-opcache-jit-use-minilua-in-sysroot.patch
create mode 100644 meta-oe/recipes-devtools/php/php/1010-Fix-opcache-jit-minilua-compiling.patch

diff --git a/meta-oe/recipes-devtools/php/php/0011-opcache-jit-use-minilua-in-sysroot.patch b/meta-oe/recipes-devtools/php/php/0011-opcache-jit-use-minilua-in-sysroot.patch
deleted file mode 100644
index 2ba0f2b771..0000000000
--- a/meta-oe/recipes-devtools/php/php/0011-opcache-jit-use-minilua-in-sysroot.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From aaa6a81cfb20f9b3c25aa22e5a472c0f2867f72c Mon Sep 17 00:00:00 2001
-From: Claude Bing <cbing@...>
-Date: Tue, 9 Nov 2021 13:11:42 -0500
-Subject: [PATCH 11/11] opcache/jit: use minilua in sysroot
-
-Signed-off-by: Claude Bing <cbing@...>
----
- ext/opcache/jit/Makefile.frag | 7 ++-----
- 1 file changed, 2 insertions(+), 5 deletions(-)
-
-diff --git a/ext/opcache/jit/Makefile.frag b/ext/opcache/jit/Makefile.frag
-index b3af5b290a..f2e737e463 100644
---- a/ext/opcache/jit/Makefile.frag
-+++ b/ext/opcache/jit/Makefile.frag
-@@ -1,9 +1,6 @@
-
--$(builddir)/minilua: $(srcdir)/jit/dynasm/minilua.c
-- $(CC) $(srcdir)/jit/dynasm/minilua.c -lm -o $@
--
--$(builddir)/jit/zend_jit_x86.c: $(srcdir)/jit/zend_jit_x86.dasc $(srcdir)/jit/dynasm/*.lua $(builddir)/minilua
-- $(builddir)/minilua $(srcdir)/jit/dynasm/dynasm.lua $(DASM_FLAGS) -o $@ $(srcdir)/jit/zend_jit_x86.dasc
-+$(builddir)/jit/zend_jit_x86.c: $(srcdir)/jit/zend_jit_x86.dasc $(srcdir)/jit/dynasm/*.lua
-+ @minilua $(srcdir)/jit/dynasm/dynasm.lua $(DASM_FLAGS) -o $@ $(srcdir)/jit/zend_jit_x86.dasc
-
- $(builddir)/jit/zend_jit.lo: \
- $(builddir)/jit/zend_jit_x86.c \
---
-2.25.1
-
diff --git a/meta-oe/recipes-devtools/php/php/1010-Fix-opcache-jit-minilua-compiling.patch b/meta-oe/recipes-devtools/php/php/1010-Fix-opcache-jit-minilua-compiling.patch
new file mode 100644
index 0000000000..6f134fabb8
--- /dev/null
+++ b/meta-oe/recipes-devtools/php/php/1010-Fix-opcache-jit-minilua-compiling.patch
@@ -0,0 +1,20 @@
+From 73ea1d44c1e6b063bfa02e12919ec8a9de3709d8 Mon Sep 17 00:00:00 2001
+From: Michael Heimpold <mhei@...>
+Date: Wed, 3 Feb 2021 22:51:34 +0100
+Subject: [PATCH] Fix opcache jit minilua compiling
+
+Signed-off-by: Michael Heimpold <mhei@...>
+---
+ ext/opcache/jit/Makefile.frag | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/ext/opcache/jit/Makefile.frag
++++ b/ext/opcache/jit/Makefile.frag
+@@ -1,6 +1,6 @@
+
+ $(builddir)/minilua: $(srcdir)/jit/dynasm/minilua.c
+- $(CC) $(srcdir)/jit/dynasm/minilua.c -lm -o $@
++ $(HOSTCC) $(srcdir)/jit/dynasm/minilua.c -lm -o $@
+
+ $(builddir)/jit/zend_jit_x86.c: $(srcdir)/jit/zend_jit_x86.dasc $(srcdir)/jit/dynasm/*.lua $(builddir)/minilua
+ $(builddir)/minilua $(srcdir)/jit/dynasm/dynasm.lua $(DASM_FLAGS) -o $@ $(srcdir)/jit/zend_jit_x86.dasc
diff --git a/meta-oe/recipes-devtools/php/php_8.0.12.bb b/meta-oe/recipes-devtools/php/php_8.0.12.bb
index 300499de5c..8d24c187ef 100644
--- a/meta-oe/recipes-devtools/php/php_8.0.12.bb
+++ b/meta-oe/recipes-devtools/php/php_8.0.12.bb
@@ -25,7 +25,7 @@ SRC_URI:append:class-target = " \
file://0006-ext-phar-Makefile.frag-Fix-phar-packaging.patch \
file://0007-sapi-cli-config.m4-fix-build-directory.patch \
file://0008-ext-imap-config.m4-fix-include-paths.patch \
- file://0011-opcache-jit-use-minilua-in-sysroot.patch \
+ file://1010-Fix-opcache-jit-minilua-compiling.patch \
file://php-fpm.conf \
file://php-fpm-apache.conf \
file://70_mod_php${PHP_MAJOR_VERSION}.conf \
@@ -108,6 +108,7 @@ PACKAGECONFIG[valgrind] = "--with-valgrind=${STAGING_DIR_TARGET}/usr,--with-valg
PACKAGECONFIG[mbregex] = "--enable-mbregex, --disable-mbregex, oniguruma"
PACKAGECONFIG[mbstring] = "--enable-mbstring,,"

+export HOSTCC = "${BUILD_CC}"
export PHP_NATIVE_DIR = "${STAGING_BINDIR_NATIVE}"
export PHP_PEAR_PHP_BIN = "${STAGING_BINDIR_NATIVE}/php"
CFLAGS += " -D_GNU_SOURCE -g -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED -I${STAGING_INCDIR}/apache2"
@@ -258,13 +259,8 @@ RCONFLICTS:${PN}-modphp = "${MODPHP_OLDPACKAGE}"
do_install:append:class-native() {
create_wrapper ${D}${bindir}/php \
PHP_PEAR_SYSCONF_DIR=${sysconfdir}/
-
- if [ "$MACHINE_ARCH" == "x86" || "$MACHINE_ARCH" == "x86-64" ]; then
- install -m 0755 ${WORKDIR}/build/ext/opcache/minilua ${D}${bindir}/
- fi
}

-
# Fails to build with thumb-1 (qemuarm)
# | {standard input}: Assembler messages:
# | {standard input}:3719: Error: selected processor does not support Thumb mode `smull r0,r2,r9,r3'





[meta-python][PATCH 5/5] python3-soupsieve: Upgrade 2.3 -> 2.3.1

Leon Anavi
 

Upgrade to release 2.3.1:

- FIX: Ensure attribute selectors match tags that have new lines
characters in attributes.

Signed-off-by: Leon Anavi <leon.anavi@...>
---
.../{python3-soupsieve_2.3.bb => python3-soupsieve_2.3.1.bb} | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
rename meta-python/recipes-devtools/python/{python3-soupsieve_2.3.bb => python3-soupsieve_2.3.1.bb} (87%)

diff --git a/meta-python/recipes-devtools/python/python3-soupsieve_2.3.bb b/meta-python/recipes-devtools/python/python3-soupsieve_2.3.1.bb
similarity index 87%
rename from meta-python/recipes-devtools/python/python3-soupsieve_2.3.bb
rename to meta-python/recipes-devtools/python/python3-soupsieve_2.3.1.bb
index 3e0e6f0ee..f4cf93dab 100644
--- a/meta-python/recipes-devtools/python/python3-soupsieve_2.3.bb
+++ b/meta-python/recipes-devtools/python/python3-soupsieve_2.3.1.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "https://github.com/facelessuser/soupsieve"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.md;md5=33c3a77def9b3ad83e01c65bdcc1af67"

-SRC_URI[sha256sum] = "e4860f889dfa88774c07da0b276b70c073b6470fa1a4a8350800bb7bce3dcc76"
+SRC_URI[sha256sum] = "b8d49b1cd4f037c7082a9683dfa1801aa2597fb11c3a1155b7a5b94829b4f1f9"

inherit pypi setuptools3 ptest

--
2.20.1


[meta-python][PATCH 4/5] python3-colorlog: Upgrade 6.5.0 -> 6.6.0

Leon Anavi
 

Upgrade to release 6.6.0:

- Add a force_color option to colorlog.formatter.ColoredFormatter
- Support the FORCE_COLOR environment variable

Signed-off-by: Leon Anavi <leon.anavi@...>
---
.../{python3-colorlog_6.5.0.bb => python3-colorlog_6.6.0.bb} | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
rename meta-python/recipes-devtools/python/{python3-colorlog_6.5.0.bb => python3-colorlog_6.6.0.bb} (75%)

diff --git a/meta-python/recipes-devtools/python/python3-colorlog_6.5.0.bb b/meta-python/recipes-devtools/python/python3-colorlog_6.6.0.bb
similarity index 75%
rename from meta-python/recipes-devtools/python/python3-colorlog_6.5.0.bb
rename to meta-python/recipes-devtools/python/python3-colorlog_6.6.0.bb
index bd9008330..2f8a0e5ca 100644
--- a/meta-python/recipes-devtools/python/python3-colorlog_6.5.0.bb
+++ b/meta-python/recipes-devtools/python/python3-colorlog_6.6.0.bb
@@ -7,4 +7,4 @@ inherit pypi setuptools3

PYPI_PACKAGE = "colorlog"

-SRC_URI[sha256sum] = "cf62a8e389d5660d0d22be17937b25b9abef9497ddc940197d1773aa1f604339"
+SRC_URI[sha256sum] = "344f73204009e4c83c5b6beb00b3c45dc70fcdae3c80db919e0a4171d006fde8"
--
2.20.1


[meta-python][PATCH 2/5] python3-zeroconf: Upgrade 0.36.12 -> 0.36.13

Leon Anavi
 

Upgrade to release 0.36.13:

- Unavailable interfaces are now skipped during socket bind
- Downgraded incoming corrupt packet logging to debug

Signed-off-by: Leon Anavi <leon.anavi@...>
---
...{python3-zeroconf_0.36.12.bb => python3-zeroconf_0.36.13.bb} | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
rename meta-python/recipes-devtools/python/{python3-zeroconf_0.36.12.bb => python3-zeroconf_0.36.13.bb} (79%)

diff --git a/meta-python/recipes-devtools/python/python3-zeroconf_0.36.12.bb b/meta-python/recipes-devtools/python/python3-zeroconf_0.36.13.bb
similarity index 79%
rename from meta-python/recipes-devtools/python/python3-zeroconf_0.36.12.bb
rename to meta-python/recipes-devtools/python/python3-zeroconf_0.36.13.bb
index 24af70eee..ccab7fe4c 100644
--- a/meta-python/recipes-devtools/python/python3-zeroconf_0.36.12.bb
+++ b/meta-python/recipes-devtools/python/python3-zeroconf_0.36.13.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "https://github.com/jstasiak/python-zeroconf"
LICENSE = "LGPL-2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=3bb705b228ea4a14ea2728215b780d80"

-SRC_URI[sha256sum] = "1f1994f550abfeda10a9d5924c7e5b463213ea5ca87198da751c74995f59e780"
+SRC_URI[sha256sum] = "196fa1bd6e166f0333e3e9fff076f9991bf2719c4788287eaec577c241ef96bf"

inherit pypi setuptools3

--
2.20.1


[meta-python][PATCH 3/5] python3-bandit: Uprade 1.7.0 -> 1.7.1

Leon Anavi
 

Upgrade to release 1.7.1:

- Fix broken reported URL link for B107
- fix reading initial values from .bandit
- Always use a Loader in yaml.load
- PEP-518 support: configure bandit via pyproject.toml

Signed-off-by: Leon Anavi <leon.anavi@...>
---
.../{python3-bandit_1.7.0.bb => python3-bandit_1.7.1.bb} | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
rename meta-python/recipes-devtools/python/{python3-bandit_1.7.0.bb => python3-bandit_1.7.1.bb} (74%)

diff --git a/meta-python/recipes-devtools/python/python3-bandit_1.7.0.bb b/meta-python/recipes-devtools/python/python3-bandit_1.7.1.bb
similarity index 74%
rename from meta-python/recipes-devtools/python/python3-bandit_1.7.0.bb
rename to meta-python/recipes-devtools/python/python3-bandit_1.7.1.bb
index 18989c6d8..ad6df1be4 100644
--- a/meta-python/recipes-devtools/python/python3-bandit_1.7.0.bb
+++ b/meta-python/recipes-devtools/python/python3-bandit_1.7.1.bb
@@ -2,8 +2,7 @@ SUMMARY = "Security oriented static analyser for python code."
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"

-SRC_URI[md5sum] = "24965f102dc62129d3fafe4fe596a3b8"
-SRC_URI[sha256sum] = "8a4c7415254d75df8ff3c3b15cfe9042ecee628a1e40b44c15a98890fbfc2608"
+SRC_URI[sha256sum] = "a81b00b5436e6880fa8ad6799bc830e02032047713cbb143a12939ac67eb756c"

DEPENDS = "python3-pbr-native python3-git python3-pbr python3-pyyaml python3-six python3-stevedore"

--
2.20.1


[meta-python][PATCH 1/5] python3-aenum: Upgrade 3.1.3 -> 3.1.5

Leon Anavi
 

Upgrade to release 3.1.5:

- fix extend_enum()
- tests: move enum setting from body to header

Signed-off-by: Leon Anavi <leon.anavi@...>
---
.../{python3-aenum_3.1.3.bb => python3-aenum_3.1.5.bb} | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
rename meta-python/recipes-devtools/python/{python3-aenum_3.1.3.bb => python3-aenum_3.1.5.bb} (65%)

diff --git a/meta-python/recipes-devtools/python/python3-aenum_3.1.3.bb b/meta-python/recipes-devtools/python/python3-aenum_3.1.5.bb
similarity index 65%
rename from meta-python/recipes-devtools/python/python3-aenum_3.1.3.bb
rename to meta-python/recipes-devtools/python/python3-aenum_3.1.5.bb
index ad7d36319..4da70b86d 100644
--- a/meta-python/recipes-devtools/python/python3-aenum_3.1.3.bb
+++ b/meta-python/recipes-devtools/python/python3-aenum_3.1.5.bb
@@ -3,8 +3,12 @@ HOMEPAGE = "https://pypi.org/project/aenum/"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://aenum/LICENSE;md5=c6a85477543f8b8591b9c1f82abebbe9"

-SRC_URI[sha256sum] = "1d494e4d3b3e3e95389aee420203d945776d2430ee9a3d4f162e267b3a7ec3a6"
+SRC_URI[sha256sum] = "2ebad8590b6a0183c0d9893523b458edce987ae4533339c5ac185cfac32daf1a"

inherit pypi setuptools3

+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-pprint \
+"
+
BBCLASSEXTEND = "native nativesdk"
--
2.20.1


Re: [meta-gnome++][PATCH 11/31] gtk4: initial add 4.4.0

Zoltan Boszormenyi
 

2021. 11. 01. 13:07 keltezéssel, Andreas Müller írta:
On Mon, Nov 1, 2021 at 12:51 PM Alexander Kanavin
<alex.kanavin@...> wrote:

Can you please name this one simply 'gtk'? There's no reason to append 4 in there.

Alex
Did this to make the difference clear and to be prepared once they
invent gtk5. What do others think?
FWIW, Red Hat ships gtk2, gtk3 and gtk4 without the "+"
and parallel installable.

I prefer "gtk4".

Andreas


Re: [meta-java] Request to pull honister branch and override syntax commits from master-next to master branch

Geoff Parker
 

I made this request a month ago, still no change to the master branch
so that builds can be made using meta-java with honister or master
openembedded layers.

On Thu, Oct 14, 2021 at 2:32 PM Geoff Parker via
lists.openembedded.org <geoffhp=gmail.com@...>
wrote:


Request that these commits that have been in meta-next for a while get
merged into master of meta-java so that builds using meta-java can be
built with master or honister core layers.

147677c layer.conf: Update to new honister release name
a1eb2b9 all: manual fixes for new override syntax
b71a986 all: run convert-overrides (0.9.3) script to convert to new
override format



Re: [meta-gnome][PATCH 7/9] tracker-miners: introspection is not valid meson option

Andreas Müller
 

On Sat, Nov 13, 2021 at 6:46 PM Khem Raj <raj.khem@...> wrote:

meson 0.60+ errors out on unknown options and -Dintrospection
is not a valid option

Signed-off-by: Khem Raj <raj.khem@...>
---
meta-gnome/recipes-gnome/tracker/tracker-miners_3.1.1.bb | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/meta-gnome/recipes-gnome/tracker/tracker-miners_3.1.1.bb b/meta-gnome/recipes-gnome/tracker/tracker-miners_3.1.1.bb
index c2de723ac9..78d4b6203d 100644
--- a/meta-gnome/recipes-gnome/tracker/tracker-miners_3.1.1.bb
+++ b/meta-gnome/recipes-gnome/tracker/tracker-miners_3.1.1.bb
@@ -20,7 +20,7 @@ SRC_URI += "file://0001-meson.build-Just-warn-if-we-build-without-libseccomp.pat

# gobject-introspection is mandatory and cannot be configured
REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
-UNKNOWN_CONFIGURE_WHITELIST:append = " introspection"
+GIR_MESON_OPTION = ""
Makes sense - thanks for taking care

Andreas

PACKAGECONFIG ??= " \
${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "ffmpeg", "", d)} \
--
2.33.1




[dunfell][PATCH] lmsensors: do not depend on lmsensors-isatools on non-x86

Martin Jansa
 

From: lumag <dbaryshkov@...>

lmsensors will build isadump and isaset only on x86 architecture.
Depending on this package breaks lmsensors on all non-x86 machines. Fix
this by enabling ${PN}-isatools dependency only on x86.

Signed-off-by: Dmitry Baryshkov <dbaryshkov@...>
Signed-off-by: Khem Raj <raj.khem@...>
Signed-off-by: Martin Jansa <Martin.Jansa@...>
---

cherry-picked from gatesgarth 428d4e6885

meta-oe/recipes-bsp/lm_sensors/lmsensors_3.6.0.bb | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/meta-oe/recipes-bsp/lm_sensors/lmsensors_3.6.0.bb b/meta-oe/recipes-bsp/lm_sensors/lmsensors_3.6.0.bb
index 890db55bcc..9c561e9f47 100644
--- a/meta-oe/recipes-bsp/lm_sensors/lmsensors_3.6.0.bb
+++ b/meta-oe/recipes-bsp/lm_sensors/lmsensors_3.6.0.bb
@@ -95,7 +95,7 @@ RDEPENDS_${PN} += " \
${PN}-sensorsdetect \
${PN}-sensorsconfconvert \
${PN}-pwmconfig \
- ${PN}-isatools \
+ ${@bb.utils.contains('MACHINE_FEATURES', 'x86', '${PN}-isatools', '', d)} \
"

# libsensors packages
--
2.32.0


Re: [meta-multimedia][PATCH 3/9] libmediaart: introspection is not valid meson option

Tim Orling
 



On Sat, Nov 13, 2021 at 9:46 AM Khem Raj <raj.khem@...> wrote:
meson 0.60+ errors out on unknown options and -Dintrospection
is not a valid option

Signed-off-by: Khem Raj <raj.khem@...>
Acked-by: Tim Orling <ticotimo@...>

Thank you for this series. I wasn’t sure what the proper solution was.

---
 .../recipes-support/libmediaart/libmediaart-2.0_1.9.5.bb        | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/meta-multimedia/recipes-support/libmediaart/libmediaart-2.0_1.9.5.bb b/meta-multimedia/recipes-support/libmediaart/libmediaart-2.0_1.9.5.bb
index 31fe43bfa7..ffedb2625e 100644
--- a/meta-multimedia/recipes-support/libmediaart/libmediaart-2.0_1.9.5.bb
+++ b/meta-multimedia/recipes-support/libmediaart/libmediaart-2.0_1.9.5.bb
@@ -18,6 +18,6 @@ S = "${WORKDIR}/libmediaart-${PV}"

 # gobject-introspection is mandatory and cannot be configured
 REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
-UNKNOWN_CONFIGURE_WHITELIST = "introspection"
+GIR_MESON_OPTION = ""

 EXTRA_OEMESON = "-Dimage_library=gdk-pixbuf"
--
2.33.1




5781 - 5800 of 99739