[meta-oe][PATCH] passwdqc: fix the libpasswdqc FILES setting


Chen Qi
 

The actual file name is now libpasswdqc.so.1 instead of libpasswdqc.so.0.
This fixes the following error when installing passwdqc:

nothing provides libpasswdqc needed by passwdqc-2.0.2-r0

Signed-off-by: Chen Qi <Qi.Chen@...>
---
meta-oe/recipes-security/passwdqc/passwdqc_2.0.2.bb | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/meta-oe/recipes-security/passwdqc/passwdqc_2.0.2.bb b/meta-oe/recipes-security/passwdqc/passwdqc_2.0.2.bb
index de4bff8c7..8462701b3 100644
--- a/meta-oe/recipes-security/passwdqc/passwdqc_2.0.2.bb
+++ b/meta-oe/recipes-security/passwdqc/passwdqc_2.0.2.bb
@@ -57,7 +57,7 @@ do_install() {
PROVIDES += "pam-${BPN}"
PACKAGES =+ "lib${BPN} pam-${BPN}"

-FILES:lib${BPN} = "${base_libdir}/libpasswdqc.so.0"
+FILES:lib${BPN} = "${base_libdir}/libpasswdqc.so.1"
FILES:pam-${BPN} = "${base_libdir}/security/pam_passwdqc.so"
FILES:${PN}-dbg += "${base_libdir}/security/.debug"

--
2.37.1

Join {openembedded-devel@lists.openembedded.org to automatically receive all group messages.