[meta-oe][PATCH 1/2] pcsc-lite: upgrade 1.9.0 -> 1.9.8


Julian Haller
 

From: Julian Haller <julian.haller@...>

The python3 related patch is no longer due to similar changes in the
project. This also requires changing the RDEPENDS to python3-core to
avoid package QA warnings.

Signed-off-by: Julian Haller <julian.haller@...>
---
.../0001-pcsc-spy-use-python3-only.patch | 43 -------------------
...{pcsc-lite_1.9.0.bb => pcsc-lite_1.9.8.bb} | 12 +++---
2 files changed, 5 insertions(+), 50 deletions(-)
delete mode 100644 meta-oe/recipes-support/pcsc-lite/pcsc-lite/0001-pcsc-spy-use-python3-only.patch
rename meta-oe/recipes-support/pcsc-lite/{pcsc-lite_1.9.0.bb => pcsc-lite_1.9.8.bb} (85%)

diff --git a/meta-oe/recipes-support/pcsc-lite/pcsc-lite/0001-pcsc-spy-use-python3-only.patch b/meta-oe/recipes-support/pcsc-lite/pcsc-lite/0001-pcsc-spy-use-python3-only.patch
deleted file mode 100644
index 3e7b0adda6..0000000000
--- a/meta-oe/recipes-support/pcsc-lite/pcsc-lite/0001-pcsc-spy-use-python3-only.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 75dd98876951d86890ceb30be521de57fd31e3c7 Mon Sep 17 00:00:00 2001
-From: Andrey Zhizhikin <andrey.z@...>
-Date: Mon, 27 Jan 2020 13:27:12 +0000
-Subject: [PATCH] pcsc-spy: use python3 only
-
-Python2 has been EOL and most distributions would not provide any
-support for it anymore. Since Python3 is available in all distributions
-now, switch pcsc-spy to use it exclusively.
-
-Upstream-Status: Pending
-
-Signed-off-by: Andrey Zhizhikin <andrey.z@...>
----
- src/spy/pcsc-spy | 9 ++-------
- 1 file changed, 2 insertions(+), 7 deletions(-)
-
-diff --git a/src/spy/pcsc-spy b/src/spy/pcsc-spy
-index 85222c6..965138e 100755
---- a/src/spy/pcsc-spy
-+++ b/src/spy/pcsc-spy
-@@ -1,4 +1,4 @@
--#! /usr/bin/python
-+#!/usr/bin/env python3
-
- """
- # Display PC/SC functions arguments
-@@ -22,12 +22,7 @@ from __future__ import print_function
- import os
- import signal
- import time
--try:
-- # for Python3
-- from queue import Queue
--except ImportError:
-- # for Python2
-- from Queue import Queue
-+from queue import Queue
- from threading import Thread
- from operator import attrgetter
-
---
-2.17.1
-
diff --git a/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.9.0.bb b/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.9.8.bb
similarity index 85%
rename from meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.9.0.bb
rename to meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.9.8.bb
index 9ae091a09a..64c9c2a9da 100644
--- a/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.9.0.bb
+++ b/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.9.8.bb
@@ -9,13 +9,11 @@ LICENSE:${PN}-dbg = "BSD-3-Clause & GPL-3.0-or-later"
LICENSE:${PN}-spy = "GPL-3.0-or-later"
LICENSE:${PN}-spy-dev = "GPL-3.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=628c01ba985ecfa21677f5ee2d5202f6"
+DEPENDS = "autoconf-archive-native"

-SRC_URI = "\
- https://pcsclite.apdu.fr/files/${BP}.tar.bz2 \
- file://0001-pcsc-spy-use-python3-only.patch \
-"
-SRC_URI[md5sum] = "eb595f2d398ff229207a6ec09fbc4e98"
-SRC_URI[sha256sum] = "0148d403137124552c5d0f10f8cdab2cbb8dfc7c6ce75e018faf667be34f2ef9"
+SRC_URI = "https://pcsclite.apdu.fr/files/${BP}.tar.bz2"
+SRC_URI[md5sum] = "d063c6ca17c17fab39a85132811e155d"
+SRC_URI[sha256sum] = "502d80c557ecbee285eb99fe8703eeb667bcfe067577467b50efe3420d1b2289"

inherit autotools systemd pkgconfig perlnative

@@ -54,6 +52,6 @@ RPROVIDES:${PN} += "${PN}-systemd"
RREPLACES:${PN} += "${PN}-systemd"
RCONFLICTS:${PN} += "${PN}-systemd"
SYSTEMD_SERVICE:${PN} = "pcscd.socket"
-RDEPENDS:${PN}-spy +="python3"
+RDEPENDS:${PN}-spy += "python3-core"

BBCLASSEXTEND = "native"
--
2.25.1

Join openembedded-devel@lists.openembedded.org to automatically receive all group messages.