[meta-python][PATCH v2] python3-pystemd: Upgrade 0.8.0 -> 0.10.0:


Johannes Schneider
 

most important fix: version 0.8.0 errors out on dbus-lib interaction,
which is fixed with the most recent commit

505e2b5 (tag: v.0.10.0) add interactive_authorization options for buses
2d90700 pystemd: add copyright boilerplate to typing stubs
5b95888 pystemd: update branch name in github workflow
16817d2 Add type stub for pystemd.run
410fd77 (tag: v.0.9.0) update changelog for 0.9.0
71aae43 GetProcesses() - info about systemd version (#59)
fcafd08 Also include .pxd and .pxi in the source distribution
475cd2f also support 3.9
ea98275 some formatting options and start pystemd 0.9 development
eb7d225 pystemd: update install instructions in README
6fdf2c8 Daily `arc lint --take BLACK`
50e61b7 add a LIBSYSTEMD_VERSION macro for gating new functions (#58)

Signed-off-by: Johannes Schneider <johannes.schneider@...>
---
.../{python3-pystemd_0.8.0.bb => python3-pystemd_0.10.0.bb} | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
rename meta-python/recipes-devtools/python/{python3-pystemd_0.8.0.bb => python3-pystemd_0.10.0.bb} (62%)

diff --git a/meta-python/recipes-devtools/python/python3-pystemd_0.8.0.bb b/meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb
similarity index 62%
rename from meta-python/recipes-devtools/python/python3-pystemd_0.8.0.bb
rename to meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb
index 0056a794f..da263fe94 100644
--- a/meta-python/recipes-devtools/python/python3-pystemd_0.8.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb
@@ -2,13 +2,12 @@ SUMMARY = "Python bindings for interacting with systemd over DBus"
LICENSE = "LGPL-2.1-only"
LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"

-SRC_URI[md5sum] = "f993739eca645749f18d4ccfd4a0fbf3"
-SRC_URI[sha256sum] = "cac2e42043ab28d43adf33dab493c6a3cf8a99794f824ae8af6d9cd6458b9972"
+SRC_URI[sha256sum] = "d74a814bfda01085db1a8ad90be3cb27daf23a51ab6b03e7e29ec811fa2ae859"

DEPENDS = "systemd"
RDEPENDS:${PN} += "python3-xml python3-pprint"
REQUIRED_DISTRO_FEATURES = "systemd"

-inherit pypi setuptools3 features_check
+inherit pypi setuptools3 features_check pkgconfig

BBCLASSEXTEND = "native"
--
2.25.1

Join openembedded-devel@lists.openembedded.org to automatically receive all group messages.