[meta-oe][PATCH 3/4] libparse-yapp-perl: update interpreter of yapp


Kai Kang
 

From: Kai Kang <kai.kang@...>

Update interpreter on shebang line of script yapp to fix qa error:

ERROR: QA Issue: : /work/x86_64-linux/libparse-yapp-perl-native/1.21-r0/sysroot-destdir
/work/x86_64-linux/libparse-yapp-perl-native/1.21-r0/recipe-sysroot-native/usr/bin/yapp
maximum shebang size exceeded, the maximum size is 128. [shebang-size]

Signed-off-by: Kai Kang <kai.kang@...>
---
meta-oe/recipes-devtools/perl/libparse-yapp-perl_1.21.bb | 4 ++++
1 file changed, 4 insertions(+)

diff --git a/meta-oe/recipes-devtools/perl/libparse-yapp-perl_1.21.bb b/meta-oe/recipes-devtools/perl/libparse-yapp-perl_1.21.bb
index d7959df66..be9704a31 100644
--- a/meta-oe/recipes-devtools/perl/libparse-yapp-perl_1.21.bb
+++ b/meta-oe/recipes-devtools/perl/libparse-yapp-perl_1.21.bb
@@ -18,4 +18,8 @@ S = "${WORKDIR}/Parse-Yapp-${PV}"

inherit cpan

+do_install:append() {
+ sed -i "s:^#!.*:#!/usr/bin/env perl:" ${D}${bindir}/yapp
+}
+
BBCLASSEXTEND = "native"
--
2.17.1

Join openembedded-devel@lists.openembedded.org to automatically receive all group messages.