Re: [meta-oe][PATCH v4 4/4] libspatialite: Upgrade to 5.0.1


Zoltan Boszormenyi
 

2022. 07. 02. 6:00 keltezéssel, Khem Raj írta:
does this need some specific version of geos ? seeing this
https://autobuilder.yoctoproject.org/typhoon/#/builders/88/builds/1813/steps/14/logs/stdio
All I can see is a single line indicating that do_configure failed,
but not the output from do_configure. Can you give me that output?

On Wed, Jun 22, 2022 at 10:17 AM Zoltan Boszormenyi via
lists.openembedded.org <zboszor=pr.hu@...> wrote:

From: Zoltán Böszörményi <zboszor@...>

Removed a patch that didn't apply to the new version.

Added three patches without changes from Fedora that allowed
the new version to compile.
See https://koji.fedoraproject.org/koji/buildinfo?buildID=1924183

Signed-off-by: Zoltán Böszörményi <zboszor@...>
---
.../libspatialite/geos-config.patch | 17 --------
.../libspatialite/libspatialite_geos.patch | 43 +++++++++++++++++++
.../libspatialite/libspatialite_macros.patch | 12 ++++++
.../libspatialite_pkgconfig.patch | 11 +++++
...alite_4.3.0a.bb => libspatialite_5.0.1.bb} | 14 +++---
5 files changed, 74 insertions(+), 23 deletions(-)
delete mode 100644 meta-oe/recipes-navigation/libspatialite/libspatialite/geos-config.patch
create mode 100644 meta-oe/recipes-navigation/libspatialite/libspatialite/libspatialite_geos.patch
create mode 100644 meta-oe/recipes-navigation/libspatialite/libspatialite/libspatialite_macros.patch
create mode 100644 meta-oe/recipes-navigation/libspatialite/libspatialite/libspatialite_pkgconfig.patch
rename meta-oe/recipes-navigation/libspatialite/{libspatialite_4.3.0a.bb => libspatialite_5.0.1.bb} (63%)

diff --git a/meta-oe/recipes-navigation/libspatialite/libspatialite/geos-config.patch b/meta-oe/recipes-navigation/libspatialite/libspatialite/geos-config.patch
deleted file mode 100644
index 28bd7dad8..000000000
--- a/meta-oe/recipes-navigation/libspatialite/libspatialite/geos-config.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-https://www.gaia-gis.it/fossil/libspatialite/tktview?name=abeeaad448
-
-Upstream-Status: Submitted [rpm5-devel@...]
-
-Index: libspatialite-4.2.0/configure.ac
-===================================================================
---- libspatialite-4.2.0.orig/configure.ac
-+++ libspatialite-4.2.0/configure.ac
-@@ -260,7 +260,7 @@ if test x"$enable_geos" != "xno"; then
- fi
- # Extract the linker and include flags
- GEOS_LDFLAGS=`$GEOSCONFIG --ldflags`
-- GEOS_CFLAGS=-I`$GEOSCONFIG --includes`
-+ GEOS_CFLAGS=`$GEOSCONFIG --cflags`
- AC_SUBST([GEOS_LDFLAGS])
- AC_SUBST([GEOS_CFLAGS])
- # Ensure that we can parse geos_c.h
diff --git a/meta-oe/recipes-navigation/libspatialite/libspatialite/libspatialite_geos.patch b/meta-oe/recipes-navigation/libspatialite/libspatialite/libspatialite_geos.patch
new file mode 100644
index 000000000..7d8d2c2e4
--- /dev/null
+++ b/meta-oe/recipes-navigation/libspatialite/libspatialite/libspatialite_geos.patch
@@ -0,0 +1,43 @@
+diff -rupN --no-dereference libspatialite-5.0.1/configure.ac libspatialite-5.0.1-new/configure.ac
+--- libspatialite-5.0.1/configure.ac 2021-03-08 08:57:19.015858195 +0100
++++ libspatialite-5.0.1-new/configure.ac 2021-03-08 08:57:19.017858195 +0100
+@@ -312,35 +312,10 @@ AC_ARG_ENABLE(geos, [AS_HELP_STRING(
+ [], [enable_geos=yes])
+ if test x"$enable_geos" != "xno"; then
+ #-----------------------------------------------------------------------
+- # --with-geosconfig
+- #
+- AC_ARG_WITH([geosconfig],
+- [AS_HELP_STRING([--with-geosconfig=FILE], [specify an alternative geos-config file])],
+- [GEOSCONFIG="$withval"], [GEOSCONFIG=""])
+- if test "x$GEOSCONFIG" = "x"; then
+- # GEOSCONFIG was not specified, so search within the current path
+- AC_PATH_PROG([GEOSCONFIG], [geos-config])
+- # If we couldn't find geos-config, display an error
+- if test "x$GEOSCONFIG" = "x"; then
+- AC_MSG_ERROR([could not find geos-config within the current path. You may need to try re-running configure with a --with-geosconfig parameter.])
+- fi
+- else
+- # GEOSCONFIG was specified; display a message to the user
+- if test "x$GEOSCONFIG" = "xyes"; then
+- AC_MSG_ERROR([you must specify a parameter to --with-geosconfig, e.g. --with-geosconfig=/path/to/geos-config])
+- else
+- if test -f $GEOSCONFIG; then
+- AC_MSG_RESULT([Using user-specified geos-config file: $GEOSCONFIG])
+- else
+- AC_MSG_ERROR([the user-specified geos-config file $GEOSCONFIG does not exist])
+- fi
+- fi
+- fi
+- # Extract the linker and include flags
+- GEOS_LDFLAGS=`$GEOSCONFIG --ldflags`
+- GEOS_CFLAGS=-I`$GEOSCONFIG --includes`
+- AC_SUBST([GEOS_LDFLAGS])
+- AC_SUBST([GEOS_CFLAGS])
++ PKG_CHECK_MODULES([GEOS], [geos], , AC_MSG_ERROR(['geos' is required but it doesn't seem to be installed on this system.]))
++ GEOS_LDFLAGS="$GEOS_LIBS"
++ AC_SUBST(GEOS_CFLAGS)
++ AC_SUBST(GEOS_LDFLAGS)
+ # Ensure that we can parse geos_c.h
+ CPPFLAGS_SAVE="$CPPFLAGS"
+ CPPFLAGS="$GEOS_CFLAGS"
diff --git a/meta-oe/recipes-navigation/libspatialite/libspatialite/libspatialite_macros.patch b/meta-oe/recipes-navigation/libspatialite/libspatialite/libspatialite_macros.patch
new file mode 100644
index 000000000..9b71ab765
--- /dev/null
+++ b/meta-oe/recipes-navigation/libspatialite/libspatialite/libspatialite_macros.patch
@@ -0,0 +1,12 @@
+diff -rupN --no-dereference libspatialite-5.0.1/configure.ac libspatialite-5.0.1-new/configure.ac
+--- libspatialite-5.0.1/configure.ac 2021-03-08 08:57:18.748858216 +0100
++++ libspatialite-5.0.1-new/configure.ac 2021-03-08 08:57:18.751858215 +0100
+@@ -96,7 +96,7 @@ AC_PROG_INSTALL
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
+ AC_LIBTOOL_WIN32_DLL
+-AC_PROG_LIBTOOL
++LT_INIT
+
+ # Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
diff --git a/meta-oe/recipes-navigation/libspatialite/libspatialite/libspatialite_pkgconfig.patch b/meta-oe/recipes-navigation/libspatialite/libspatialite/libspatialite_pkgconfig.patch
new file mode 100644
index 000000000..149c12676
--- /dev/null
+++ b/meta-oe/recipes-navigation/libspatialite/libspatialite/libspatialite_pkgconfig.patch
@@ -0,0 +1,11 @@
+diff -rupN libspatialite-5.0.1/spatialite.pc.in libspatialite-5.0.1-new/spatialite.pc.in
+--- libspatialite-5.0.1/spatialite.pc.in 2021-02-07 16:53:46.000000000 +0100
++++ libspatialite-5.0.1-new/spatialite.pc.in 2021-02-10 09:54:09.647552994 +0100
+@@ -8,5 +8,6 @@ includedir=@includedir@
+ Name: spatialite
+ Description: Spatial SQL database engine based on SQLite
+ Version: @VERSION@
+-Libs: -L${libdir} -lspatialite @LIBS@ @LIBXML2_LIBS@ -lm
++Libs.private: -L${libdir} @LIBS@ @LIBXML2_LIBS@ -lm
++Libs: -L${libdir} -lspatialite
+ Cflags: -I${includedir}
diff --git a/meta-oe/recipes-navigation/libspatialite/libspatialite_4.3.0a.bb b/meta-oe/recipes-navigation/libspatialite/libspatialite_5.0.1.bb
similarity index 63%
rename from meta-oe/recipes-navigation/libspatialite/libspatialite_4.3.0a.bb
rename to meta-oe/recipes-navigation/libspatialite/libspatialite_5.0.1.bb
index f6c765519..f46b1083e 100644
--- a/meta-oe/recipes-navigation/libspatialite/libspatialite_4.3.0a.bb
+++ b/meta-oe/recipes-navigation/libspatialite/libspatialite_5.0.1.bb
@@ -7,14 +7,16 @@ LICENSE = "MPL-1.1 & GPL-2.0-or-later & LGPL-2.1-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=0e92e1a36cc384b60f5b31dde0bdd39e"

SRC_URI = "http://www.gaia-gis.it/gaia-sins/libspatialite-sources/libspatialite-${PV}.tar.gz \
- file://geos-config.patch"
-SRC_URI[md5sum] = "6b380b332c00da6f76f432b10a1a338c"
-SRC_URI[sha256sum] = "88900030a4762904a7880273f292e5e8ca6b15b7c6c3fb88ffa9e67ee8a5a499"
+ file://libspatialite_geos.patch \
+ file://libspatialite_macros.patch \
+ file://libspatialite_pkgconfig.patch \
+"

-inherit autotools pkgconfig
+SRC_URI[sha256sum] = "eecbc94311c78012d059ebc0fae86ea5ef6eecb13303e6e82b3753c1b3409e98"

-EXTRA_OECONF = "--enable-freexl=no"
-CFLAGS += "-DACCEPT_USE_OF_DEPRECATED_PROJ_API_H"
+inherit autotools-brokensep pkgconfig
+
+EXTRA_OECONF = "--enable-freexl=no --disable-rttopo --disable-minizip"

# package plugins for SQLite3
PACKAGES += "${PN}-plugin"
--
2.36.1


Join {openembedded-devel@lists.openembedded.org to automatically receive all group messages.