Re: [meta-oe][PATCH] p8platform: unbreak do_populate_sdk


Martin Jansa
 

Replace this with

RDEPENDS:${PN}-dev = ""

On Tue, May 24, 2022 at 5:19 PM Markus Volk <f_l_k@...> wrote:
Error:
 Problem: package libcec-dev-6.0.2-r0.corei7_64 requires p8platform-dev, but none of the providers can be installed
  - conflicting requests
  - nothing provides p8platform = 2.1.0.1-r0 needed by p8platform-dev-2.1.0.1-r0.corei7_64
(try to add '--skip-broken' to skip uninstallable packages)

Signed-off-by: Markus Volk <f_l_k@...>
---
 meta-oe/recipes-extended/p8platform/p8platform_git.bb | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/meta-oe/recipes-extended/p8platform/p8platform_git.bb b/meta-oe/recipes-extended/p8platform/p8platform_git.bb
index 8a0699057..777c6c7ca 100644
--- a/meta-oe/recipes-extended/p8platform/p8platform_git.bb
+++ b/meta-oe/recipes-extended/p8platform/p8platform_git.bb
@@ -17,3 +17,5 @@ inherit cmake pkgconfig
 EXTRA_OECMAKE += "-DCMAKE_INSTALL_LIBDIR=${libdir} -DCMAKE_INSTALL_LIBDIR_NOARCH=${libdir}"

 FILES:${PN}-dev += "${libdir}/p8-platform"
+
+ALLOW_EMPTY:${PN} = "1"
--
2.25.1




Join openembedded-devel@lists.openembedded.org to automatically receive all group messages.