[meta-oe][PATCH] libgusb: add PACKAGECONFIG for vapi and keep it enabled only when introspection is


Martin Jansa
 

* vapi depends on introspection being enabled and libgusb build was failing
without introspection with:
| ../git/gusb/meson.build:182:6: ERROR: Unknown variable "libgusb_girtarget".

Signed-off-by: Martin Jansa <Martin.Jansa@...>
---
meta-oe/recipes-support/libgusb/libgusb_0.3.8.bb | 3 +++
1 file changed, 3 insertions(+)

diff --git a/meta-oe/recipes-support/libgusb/libgusb_0.3.8.bb b/meta-oe/recipes-support/libgusb/libgusb_0.3.8.bb
index 7020ced72c..51e7349043 100644
--- a/meta-oe/recipes-support/libgusb/libgusb_0.3.8.bb
+++ b/meta-oe/recipes-support/libgusb/libgusb_0.3.8.bb
@@ -6,6 +6,9 @@ DEPENDS = "glib-2.0 libusb"

inherit meson gobject-introspection gtk-doc gettext vala

+PACKAGECONFIG ??= "${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'vapi', '', d)}"
+PACKAGECONFIG[vapi] = "-Dvapi=true,-Dvapi=false"
+
SRC_URI = "git://github.com/hughsie/libgusb.git;branch=main;protocol=https"
SRCREV = "db9edbd8b45662d551194a0985173732f8f557a5"
S = "${WORKDIR}/git"
--
2.32.0

Join openembedded-devel@lists.openembedded.org to automatically receive all group messages.