[meta-oe][PATCH] ntpsec: require x11 in DISTRO_FEATURES


Martin Jansa
 

* fixes:
ERROR: Nothing RPROVIDES 'gnuplot' (but meta-openembedded/meta-networking/recipes-support/ntpsec/ntpsec_1.2.1.bb RDEPENDS on or otherwise requires it)
gnuplot was skipped: missing required distro feature 'x11' (not in DISTRO_FEATURES)
NOTE: Runtime target 'gnuplot' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['gnuplot']
NOTE: Runtime target 'ntpsec' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['ntpsec', 'gnuplot']
NOTE: Runtime target 'ntpsec-python' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['ntpsec-python', 'gnuplot']
ERROR: Nothing RPROVIDES 'ntpsec-dev' (but meta-openembedded/meta-networking/recipes-support/ntpsec/ntpsec_1.2.1.bb RDEPENDS on or otherwise requires it)
No eligible RPROVIDERs exist for 'ntpsec-dev'
NOTE: Runtime target 'ntpsec-dev' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['ntpsec-dev']

Signed-off-by: Martin Jansa <Martin.Jansa@...>
---
.../packagegroups/packagegroup-meta-networking.bb | 2 +-
meta-networking/recipes-support/ntpsec/ntpsec_1.2.1.bb | 5 ++++-
2 files changed, 5 insertions(+), 2 deletions(-)

diff --git a/meta-networking/recipes-core/packagegroups/packagegroup-meta-networking.bb b/meta-networking/recipes-core/packagegroups/packagegroup-meta-networking.bb
index 3e3297c262..a539dfeb6c 100644
--- a/meta-networking/recipes-core/packagegroups/packagegroup-meta-networking.bb
+++ b/meta-networking/recipes-core/packagegroups/packagegroup-meta-networking.bb
@@ -217,7 +217,7 @@ RDEPENDS:packagegroup-meta-networking-support = "\
yp-tools \
mtr \
ntp ntpdate sntp ntpdc ntpq ntp-tickadj ntp-utils \
- ntpsec \
+ ${@bb.utils.contains("DISTRO_FEATURES", "x11", "ntpsec", "", d)} \
nbd-client \
nbd-server \
nbd-trdump \
diff --git a/meta-networking/recipes-support/ntpsec/ntpsec_1.2.1.bb b/meta-networking/recipes-support/ntpsec/ntpsec_1.2.1.bb
index 167af04ca4..d07cac4265 100644
--- a/meta-networking/recipes-support/ntpsec/ntpsec_1.2.1.bb
+++ b/meta-networking/recipes-support/ntpsec/ntpsec_1.2.1.bb
@@ -17,7 +17,10 @@ SRC_URI = "https://ftp.ntpsec.org/pub/releases/ntpsec-${PV}.tar.gz \

SRC_URI[sha256sum] = "f2684835116c80b8f21782a5959a805ba3c44e3a681dd6c17c7cb00cc242c27a"

-inherit pkgconfig python3-dir python3targetconfig systemd update-alternatives update-rc.d useradd waf
+inherit pkgconfig python3-dir python3targetconfig systemd update-alternatives update-rc.d useradd waf features_check
+
+# RDEPENDS on gnuplot with this restriction
+REQUIRED_DISTRO_FEATURES = "x11"

PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'seccomp systemd', d)} \
cap \
--
2.32.0

Join openembedded-devel@lists.openembedded.org to automatically receive all group messages.