[meta-python2][PATCH] python-pywbem-native: openlmi-tools: blacklist due to openssl-3


Martin Jansa
 

* blacklist python-pywbem-native as well, because native python-m2crypto is blacklisted:
ERROR: Nothing PROVIDES 'python-m2crypto-native' (but virtual:native:meta-python2/recipes-extended/pywbem/python-pywbem_0.15.0.bb DEPENDS on or otherwise requires it)
python-m2crypto-native was skipped: Recipe is blacklisted: Not compatible with openssl-3, http://errors.yoctoproject.org/Errors/Details/614896/ SWIG/_m2crypto_wrap.c:32981:102: error: RSA_SSLV23_PADDING undeclared (first use in this function); did you mean RSA_NO_PADDING?

* move openlmi-tools blacklist from python2-target-recipes-blacklist.inc to
layer.conf, because python-pywbem/python-m2crypto are blacklisted even
when python2-target-recipes-blacklist.inc isn't included in DISTRO config
so openlmi-tools need the same to fix:

ERROR: Nothing PROVIDES 'python-m2crypto' (but meta-openembedded/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb DEPENDS on or otherwise requires it)
python-m2crypto was skipped: Recipe is blacklisted: Not compatible with openssl-3, http://errors.yoctoproject.org/Errors/Details/614896/ SWIG/_m2crypto_wrap.c:32981:102: error: RSA_SSLV23_PADDING undeclared (first use in this function); did you mean RSA_NO_PADDING?
ERROR: Nothing PROVIDES 'python-pywbem' (but meta-openembedded/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb DEPENDS on or otherwise requires it)
python-pywbem was skipped: Recipe is blacklisted: depends on python-m2crypto which fails to build with openssl-3
ERROR: Nothing RPROVIDES 'openlmi-tools' (but meta-openembedded/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb RDEPENDS on or otherwise requires it)
No eligible RPROVIDERs exist for 'openlmi-tools'
NOTE: Runtime target 'openlmi-tools' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['openlmi-tools']
ERROR: Nothing RPROVIDES 'openlmi-tools-dev' (but meta-openembedded/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb RDEPENDS on or otherwise requires it)
No eligible RPROVIDERs exist for 'openlmi-tools-dev'
NOTE: Runtime target 'openlmi-tools-dev' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['openlmi-tools-dev']

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
conf/distro/include/python2-target-recipes-blacklist.inc | 3 ---
conf/layer.conf | 4 ++++
recipes-extended/pywbem/python-pywbem_0.15.0.bb | 1 +
3 files changed, 5 insertions(+), 3 deletions(-)

diff --git a/conf/distro/include/python2-target-recipes-blacklist.inc b/conf/distro/include/python2-target-recipes-blacklist.inc
index 9480297..9b9a0eb 100644
--- a/conf/distro/include/python2-target-recipes-blacklist.inc
+++ b/conf/distro/include/python2-target-recipes-blacklist.inc
@@ -7,6 +7,3 @@ RDEPENDS:packagegroup-meta-oe-dbs-python2:remove = "${@bb.utils.contains('I_SWEA
# meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb
PNBLACKLIST[lio-utils] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
RDEPENDS:packagegroup-meta-oe-support-python2:remove = "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'lio-utils', d)}"
-# meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb
-PNBLACKLIST[openlmi-tools] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', 'depends on python-m2crypto which fails to build with openssl-3', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
-RDEPENDS:packagegroup-meta-oe-extended-python2:remove = "openlmi-tools"
diff --git a/conf/layer.conf b/conf/layer.conf
index 2142b9a..4b3a106 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -17,3 +17,7 @@ LAYERDEPENDS_meta-python2 = "core openembedded-layer"
LAYERSERIES_COMPAT_meta-python2 = "honister"

LICENSE_PATH += "${LAYERDIR}/licenses"
+
+# meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb
+PNBLACKLIST[openlmi-tools] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', 'depends on python-m2crypto which fails to build with openssl-3', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
+RDEPENDS:packagegroup-meta-oe-extended-python2:remove = "openlmi-tools"
diff --git a/recipes-extended/pywbem/python-pywbem_0.15.0.bb b/recipes-extended/pywbem/python-pywbem_0.15.0.bb
index 6604452..40a0545 100644
--- a/recipes-extended/pywbem/python-pywbem_0.15.0.bb
+++ b/recipes-extended/pywbem/python-pywbem_0.15.0.bb
@@ -68,3 +68,4 @@ ALTERNATIVE_PRIORITY = "30"
BBCLASSEXTEND = "native"

PNBLACKLIST[python-pywbem] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', 'depends on python-m2crypto which fails to build with openssl-3', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
+PNBLACKLIST[python-pywbem-native] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', 'depends on python-m2crypto which fails to build with openssl-3', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
--
2.32.0

Join openembedded-devel@lists.openembedded.org to automatically receive all group messages.