Re: [PATCH 23/24] luaposix: update 33.4.0 -> 35.1


Martin Jansa
 

Thanks, target libxcrypt worked here.


On Wed, Oct 20, 2021 at 7:14 PM Alexander Kanavin <alex.kanavin@...> wrote:
That should be libxcrypt, not libxcrypt-native.

For some reason Khem replaced my update patch with his, and somehow it does not have libscrypt:

What happened, why was my patch not taken?

Alex





On Wed, 20 Oct 2021 at 18:47, Martin Jansa <martin.jansa@...> wrote:
On Mon, Oct 11, 2021 at 8:42 PM Alexander Kanavin <alex.kanavin@...> wrote:
Drop autotools/makefile patch and change the build system to luke,
as upstream uses that now.

Any idea why it fails?

luaposix/35.1-r0/git$ build-aux/luke
luke: fatal: required symbol 'crypt' not found in any of libc, libcrypt

I already have a fix from Khem:

but it doesn't seem enough.

Join openembedded-devel@lists.openembedded.org to automatically receive all group messages.