Re: [meta-gnome][dunfell][PATCH] sysprof: depend on polkit only if DISTRO_FEATURES has it


Martin Jansa
 


On Tue, Jun 8, 2021 at 6:59 AM akash hadke <akash.hadke@...> wrote:
From: Mikko Rapeli <mikko.rapeli@...>

Fixes yocto-check-layer error:

ERROR: Nothing PROVIDES 'polkit' (but /home/builder/src/base/meta-openembedded/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb DEPENDS on or otherwise requires it)
polkit was skipped: missing required distro feature 'polkit' (not in DISTRO_FEATURES)
ERROR: Required build target 'meta-world-pkgdata' has no buildable providers.

Signed-off-by: Mikko Rapeli <mikko.rapeli@...>
Signed-off-by: akash hadke <akash.hadke@...>
---
 meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb b/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb
index ad69ab6..87acb29 100644
--- a/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb
+++ b/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb
@@ -16,7 +16,10 @@ SRC_URI += "file://0001-sysprof-Define-NT_GNU_BUILD_ID-if-undefined.patch \
             file://0001-libsysprof-ui-Rename-environ-to-sys_environ.patch \
             "

-PACKAGECONFIG ?= "sysprofd libsysprof ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'gtk', '', d)}"
+PACKAGECONFIG ?= " \
+     ${@bb.utils.contains_any('DISTRO_FEATURES', 'polkit', 'sysprofd libsysprof', '', d)} \
+     ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'gtk', '', d)} \
+"
 PACKAGECONFIG[gtk] = "-Denable_gtk=true,-Denable_gtk=false,gtk+3 libdazzle"
 PACKAGECONFIG[sysprofd] = "-Dwith_sysprofd=bundled,-Dwith_sysprofd=none,polkit"
 PACKAGECONFIG[libsysprof] = "-Dlibsysprof=true,-Dlibsysprof=false,polkit"
--
2.7.4




Join openembedded-devel@lists.openembedded.org to automatically receive all group messages.