Re: error: #error "TLS support is required." while building glibc-initial-2.4 on x86_64 #error


Koen Kooi <koen@...>
 

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Jamie Lenehan schreef:
On Wed, Sep 06, 2006 at 11:24:32PM +0200, Christopher Lang wrote:
I tried to start a fully renewed oe build system today with bitbake 1.6 and up
to date oe checkout. I am using minimal distro/machine files.
While building bootstrap-image/glibc-initial-2.4 on an x86_64 (AMD X2) machine
for TARGET_ARCH = "i586" I get the following error:
You need to use make 3.81 to build glibc 2.4 for x86 targets on x86_64.

I've added make 3.81 to OE (by copying all the 3.80 releated make
files to 3.81 versions - no changes necessary) and then do a "bitbake
make-native" prior to building rather than update the host version of
make.
Are there any nasty side-effects of update to 3.81? If not, could you commit it?

regards,

Koen

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (Darwin)

iD8DBQFFAn+UMkyGM64RGpERAhY9AJwJwaK3y+6e7uS3zoAZLv54lFNRvgCgslGZ
pOtvGXFNV/JOxnAwFHQwKyI=
=QrH5
-----END PGP SIGNATURE-----

Join openembedded-devel@lists.openembedded.org to automatically receive all group messages.