[Bug 1353] New: gpe-session-scripts shouldn't depend on gpe-bluetooth


bugzilla-daemon@...
 

http://bugs.openembedded.org/show_bug.cgi?id=1353

Summary: gpe-session-scripts shouldn't depend on gpe-bluetooth
Product: Openembedded
Version: OpenZaurus 3.5.4.x
Platform: ARM
OS/Version: Linux
Status: NEW
Severity: normal
Priority: P4
Component: Build
AssignedTo: openembedded-devel@...
ReportedBy: hma@...
QAContact: tinderbox-oe@...


gpe-session-scripts is essential package to login to /logout from GPE.
Now the package depends on gpe-bluetooth.

SL-C700 doesn't have bluetooth facility.
I want more free space rather than unused package,
so tried to remove gpe-bluetooth package.
After that, I can't login to GPE, because gpe-session-scripts also removed.

I replaced the lines in gpe-session-scripts_0.66.bb.
Is this reasonable solution?

#RDEPENDS_${PN} = "matchbox gpe-session-starter gpe-bluetooth xstroke xtscal
gpe
-question gpe-clock matchbox-applet-inputmanager xrandr xmodmap xdpyinfo
xserver
-common"
RDEPENDS_${PN} = "matchbox gpe-session-starter xstroke xtscal gpe-question
gpe-c
lock matchbox-applet-inputmanager xrandr xmodmap xdpyinfo xserver-common"

and

-DEPENDS = "matchbox-wm matchbox-panel gpe-bluetooth xstroke xtscal
gpe-question
matchbox-applet-inputmanager gpe-clock xrandr xmodmap xdpyinfo xserver-common"
+DEPENDS = "matchbox-wm matchbox-panel xstroke xtscal gpe-question
matchbox-apple
t-inputmanager gpe-clock xrandr xmodmap xdpyinfo xserver-common"


--
Configure bugmail: http://bugs.openembedded.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

Join openembedded-devel@lists.openembedded.org to automatically receive all group messages.