Re: [PATCH] mesa: update 22.2.3 -> 22.3.0

Martin Jansa


Similar mesa upgrade was merged recently:

qtbase still fails the same, more details in:

The change you've mentioned is the one which actually breaks some PACKAGECONFIG combinations, hopefully now you'll be able to reproduce it.


On Thu, Dec 8, 2022 at 8:55 AM Martin Jansa via <> wrote:
On Thu, Dec 8, 2022 at 8:42 AM Samuli Piippo <samuli.piippo@...> wrote:
Qt6 should handle this already with in place.
I tried test build with the mesa upgrade and didn't catch any build errors.

I've tried qemux86-64 build with 6.4.1 and 6.5.0 from yesterday's dev branch and both failed after including this mesa upgrade with:
| In file included from qtbase/6.4.1-r0/recipe-sysroot/usr/include/EGL/egl.h:20,
|                  from qtbase/6.4.1-r0/build/include/QtGui/6.4.1/QtGui/private/../../../../../../git/src/gui/opengl/platform/egl/qt_egl_p.h:43,
|                  from qtbase/6.4.1-r0/build/include/QtGui/6.4.1/QtGui/private/qt_egl_p.h:1,
|                  from qtbase/6.4.1-r0/git/src/gui/opengl/platform/egl/qeglstreamconvenience_p.h:20,
|                  from qtbase/6.4.1-r0/git/src/gui/opengl/platform/egl/qeglstreamconvenience.cpp:4:
| qtbase/6.4.1-r0/recipe-sysroot/usr/include/EGL/eglplatform.h:109:10: fatal error: X11/Xlib.h: No such file or directory
|   109 | #include <X11/Xlib.h>
|       |          ^~~~~~~~~~~~
| compilation terminated.

Join { to automatically receive all group messages.