Re: [PATCH v2] convert-variables: Script for Inclusive Language variable renames


Enrico Scholz
 

Richard Purdie <richard.purdie@...> writes:

This script searches for a list of variable that have been renamed
and converts them to their more descriptive names.
s/descriptive/politically correct/


again: most of these renamings make identifiers much less descriptive
because they now sound like boolean flags instead of lists
Whilst you could say they sound like booleans, they clearly can't be
as that wouldn't make sense, e.g. "Ignoring variables in basehash"
makes no sense.
True; because it does not make sense, these variables should not be
named in this way.


Secondly, most metadata variables are lists of things.
The renamed ones; yes. But when I look in bitbake.conf, I can not say
that most variables are lists.


Adding "LIST" to every variable that is a list of items would just make
the variable names much longer with little end resulting readability
gain.
True; explicit type annotations like in the hungarian notation are
nonsense. But "whitelist" and "blacklist" are words with a meaning;
the "list" is not used as a type annotation there.

Variable names were perfectly readable. A change should make things
better, not worse.


Unfortunately there likely isn't a perfect rename and these were the
best we were able to come up with.
Why is the rename done at all? It makes the product just worse due to a
less usable api and because it causes a lot of work for the users of the
api (I shudder when I think about updating my CI to work with new and
old branches).



Enrico

Join openembedded-core@lists.openembedded.org to automatically receive all group messages.