Re: [PATCH] libva: move wayland PACKAGECONFIG to

Alexander Kanavin

Right, then the correct fix is to move all PACKAGECONFIG options to, then set
PACKAGECONFIG ?= "" in libva-initial.


On Sat, 11 Dec 2021 at 11:00, Markus Volk <f_l_k@...> wrote:

I was able to narrow the issue down a little bit. I can reproduce it with plain poky by adding this to local.conf

PACKAGECONFIG:append:pn-libdrm = " udev"
DISTRO_FEATURES:append = " systemd"

and do

'bitbake libva-initial'

Am 10.12.21 um 16:47 schrieb Khem Raj:

On Fri, Dec 10, 2021 at 6:33 AM Markus Volk <f_l_k@...> wrote:

Thats strange indeed. Wayland is set as a DISTRO_FEATURE for my image, so it gets built by a lot of packages. This wasn't a clean build, i had sstate cache availbale when i started to experiment with libva and normally it doesn't get  built inside my image because i can't use it on my board. First i did 'bitbake libva' and this succeeded. Second i added 'va' PACKAGECONFIG to a mesa.bbappend and started rebuilding the image. Now the build for libva-initial was started and failed with the error about missing wayland-scanner.

I also wondered what is pulling  wayland into  its sysroot . Did 'bitbake -c cleanstate libva-initial libva' and tried to build libva-initial again with 'bitbake libva-initial' and had the same issue. On my machine this is reproducible

Post configure logs including meson run  logs for this package perhaps there is some hint in there 


Am 10.12.21 um 15:06 schrieb Alexander Kanavin:
| Run-time dependency wayland-client found: YES 1.19.0

Can you please explain how the issue can be reproduced? I find it odd that libva-initial (which only needs libdrm, and is required by mesa) has wayland in its sysroot in your build - where does that come from? There's a chance the problem is elsewhere.


On Fri, 10 Dec 2021 at 15:03, Markus Volk <f_l_k@...> wrote:
I encountered an error while trying to build libva under wayland. libva-initial
was missing wayland-native dependency and failed like this:

| Run-time dependency xfixes found: NO (tried pkgconfig and cmake)
| Run-time dependency wayland-client found: YES 1.19.0
| Program wayland-scanner /usr/bin/wayland-scanner found: NO
| ../libva-2.13.0/ ERROR: Program 'wayland-scanner /usr/bin/wayland-scanner' not found
| A full log can be found at /home/flk/build/poky/build-rock/tmp/work/cortexa72-cortexa53-crypto-poky-linux/libva-initial/2.13.0-r0/build/meson-logs/meson-log.txt
| ERROR: meson failed
| WARNING: exit code 1 from a shell command.

This commit moves the PACKAGECONFIG[wayland] to to make it available to libva-initial also

Signed-off-by: MarkusVolk <f_l_k@...>
 meta/recipes-graphics/libva/       | 7 +++++++
 meta/recipes-graphics/libva/ | 4 +---
 2 files changed, 8 insertions(+), 3 deletions(-)

diff --git a/meta/recipes-graphics/libva/ b/meta/recipes-graphics/libva/
index bcf9757c1a..0e2721e291 100644
--- a/meta/recipes-graphics/libva/
+++ b/meta/recipes-graphics/libva/
@@ -27,3 +27,10 @@ UPSTREAM_CHECK_URI = ""
 DEPENDS = "libdrm"

 inherit meson pkgconfig
+PACKAGECONFIG:append = " \
+    ${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)} \
+PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland"
diff --git a/meta/recipes-graphics/libva/ b/meta/recipes-graphics/libva/
index ed2be289fc..a8c6355b01 100644
--- a/meta/recipes-graphics/libva/
+++ b/meta/recipes-graphics/libva/
@@ -2,14 +2,12 @@ require

     ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', '', d)} \
-    ${@bb.utils.filter('DISTRO_FEATURES', 'x11 wayland', d)} \
+    ${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \

 PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxext libxfixes"
 PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/mesa"

-PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland"
 PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"

 RDEPENDS:${PN}-x11 =+ "${PN}"


Join to automatically receive all group messages.