Re: Inclusive Language - wiki page

Michael Opdenacker


On 7/7/21 5:22 PM, Mark Hatle wrote:
In the variables table:

PNBLACKLIST, I'd prefer PNEXCLUDELIST, or PNBLOCKLIST. (I think exclude better
captures what it does.)

Confused, where it says current name is whitelist, suggested rename is
'excludelist', isn't that the exact opposite?

SSTATE_DUPWHITELIST, this is really a list of things to ignore. So my

CVE_CHECK_PN_WHITELIST, I think there is a typo in the table for the replacement
(missing an L). But like the above, I think ignore is a better word then skip
here. So my suggestion would be CVE_CHECK_PN_IGNORELIST.
Instead of "includelist" and "excludelist", what about just "includes"
and "excludes"? This terminology is already used in rsync's manual (for
example), and it seems lighter and clear enough.

For example, we could replace "CECC_USER_CLASS_BL" by

Any thoughts? I mentioned this on the wiki page
(, but don't
hesitate to revert my edits.



Michael Opdenacker, Bootlin
Embedded Linux and Kernel engineering

Join { to automatically receive all group messages.