[Bug 4210] New: Unrecognised cp switch used in autotools.bbclass

bugzilla-daemon at amethyst.openembedded.net bugzilla-daemon at amethyst.openembedded.net
Thu May 1 15:34:19 UTC 2008


http://bugs.openembedded.net/show_bug.cgi?id=4210

           Summary: Unrecognised cp switch used in autotools.bbclass       
    Classification: Unclassified                                           
           Product: Openembedded                                           
           Version: unspecified                                            
          Platform: PC                                                     
        OS/Version: Linux                                                  
            Status: UNCONFIRMED                                            
          Severity: minor                                                  
          Priority: P3                                                     
         Component: Build                                                  
        AssignedTo: openembedded-issues at lists.openembedded.org             
        ReportedBy: michael at araneidae.co.uk                                


Created an attachment (id=9329)
 --> (http://bugs.openembedded.net/attachment.cgi?id=9329)
Patch to fix unrecognises switch

classes/autotools.bbclass uses the -t switch on cp.  Unfortunately this is not
recognises on older Linux installations, for example Red Hat Enterprise Linux
version 4 does not recognise this switch.  The attached patch replaces this
with the equivalent --target-directory switch (though I have to confess I fail
to see what's wrong with putting the target directory at the end of the
argument list!)

-- 
Configure bugmail: http://bugs.openembedded.net/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.




More information about the Openembedded-issues mailing list