[Bug 4369] New: binutils-2.17 won't build for AVR32

bugzilla-daemon at amethyst.openembedded.net bugzilla-daemon at amethyst.openembedded.net
Mon Jun 9 18:58:07 UTC 2008


http://bugs.openembedded.net/show_bug.cgi?id=4369

           Summary: binutils-2.17 won't build for AVR32
    Classification: Unclassified
           Product: Openembedded
           Version: Angstrom 2008.x
          Platform: Other
        OS/Version: Linux
            Status: UNCONFIRMED
          Keywords: patch
          Severity: minor
          Priority: P3
         Component: org.openembedded.dev
        AssignedTo: openembedded-issues at lists.openembedded.org
        ReportedBy: gwossum at acm.org


Created an attachment (id=9783)
 --> (http://bugs.openembedded.net/attachment.cgi?id=9783)
Make binutils 2.17 build for the AVR32 again

binutils-2.17 won't build for the AVR32 with what is currently in
org.openembedded.dev.  The attached patch fixes that, but I haven't tested it
for other architectures.  I think removing "--program-prefix=${TARGET_PREFIX}"
from EXTRA_OECONF will be safe for other platforms, but I'm haven't tested it.

Since binutils for the AVR32 will rerun autoconf, it will use autoconf 2.61,
which changes the semantics of "--program-prefix" when used in combination with
cross-compiling.  This causes the resulting binaries to have names like
"avr32-angstrom-linux-uclibc-avr32-angstrom-linux-uclibc-ar".

-- 
Configure bugmail: http://bugs.openembedded.net/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.




More information about the Openembedded-issues mailing list