[oe-issues] [Bug 2483] New: Perl 5.8.8 (r20) does not build (slugosbe)

bugzilla-daemon at tinman.treke.net bugzilla-daemon at tinman.treke.net
Wed Jun 13 17:06:23 UTC 2007


http://bugs.openembedded.org/show_bug.cgi?id=2483

           Summary: Perl 5.8.8 (r20) does not build (slugosbe)
           Product: Openembedded
           Version: unspecified
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Build
        AssignedTo: openembedded-issues at lists.openembedded.org
        ReportedBy: treitmayr at yahoo.com
         QAContact: tinderbox-oe at gmx.net


I tried to build perl 5.8.8 for slugosbe on a PC GNU/Linux machine but ran into
various problems:

1. Invalid command-line for gcc

          CCCMD =  ccache armeb-linux-gcc -march=armv5te -mtune=xscale
-mthumb-interwork -mno-thumb -DPERL_CORE -c -isystem/home/nslu2/s
lugosbe/tmp/staging/armeb-linux/include -fexpensive-optimizations
-fomit-frame-pointer -frename-registers -Os -D_REENTRANT -D_GNU_SOURCE
 -DTHREADS_HAVE_PIDS -fno-strict-aliasing -pipe-D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -O2  -Wall
armeb-linux-gcc: unrecognized option '-pipe-D_LARGEFILE_SOURCE'

   I traced it back to line 38 of generate-sh.patch, which currently reads:

+               $value =~ s#\W-I/usr/local/\w+\W##g;

   removing the both blanks surrounding the include path. A corrected version
works:

+               $value =~ s#\W-I/usr/local/\w+\W# #g;

2. miniperl does not find the correct libraries

LD_LIBRARY_PATH=/home/nslu2/slugosbe/tmp/work/armv5teb-linux/perl-5.8.8-r20/perl-5.8.8
./miniperl -Ilib configpm --heavy=lib/Config_heav
y.pl lib/Config.pm
./miniperl: error while loading shared libraries:
/home/nslu2/slugosbe/tmp/work/armv5teb-linux/perl-5.8.8-r20/perl-5.8.8/libperl.so:
ELF
 file data encoding not little-endian

   I manually changed the path in Makefile.SH to point to the libraries in the
i686-linux subdirectory, but this was just a temporary fix.

3. hostperl is not found

[..]
make[2]: Entering directory
`/home/nslu2/slugosbe/tmp/work/armv5teb-linux/perl-5.8.8-r20/perl-5.8.8/ext/attrs'
*** Module name IN: ../../lib/Cwd.pm
*** Module name OUT:
/home/nslu2/slugosbe/tmp/staging/i686-linux/lib/perl/5.8.8/Cwd.pm
*** Module name IN:
/home/nslu2/slugosbe/tmp/staging/i686-linux/lib/perl/5.8.8/List/Util.pm
*** Module name OUT:
/home/nslu2/slugosbe/tmp/staging/i686-linux/lib/perl/5.8.8/List/Util.pm
cp attrs.pm ../../lib/attrs.pm
hostperl
-I/home/nslu2/slugosbe/tmp/work/armv5teb-linux/perl-5.8.8-r20/perl-5.8.8/Cross/../fake_config_library
-MConfig ../../lib/ExtUti
ls/xsubpp -noprototypes -typemap ../../lib/ExtUtils/typemap  attrs.xs >
attrs.xsc && mv attrs.xsc attrs.c
/bin/sh: hostperl: command not found

   Adding
/home/nslu2/slugosbe/tmp/work/armv5teb-linux/perl-5.8.8-r20/perl-5.8.8 to my
PATH env. variable fixed it, but again that's just a temporary solution.

With these changes I finally managed to build the perl package.
-Thomas


-- 
Configure bugmail: http://bugs.openembedded.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.




More information about the Openembedded-issues mailing list