[oe] qemu: fails to build without zlib-dev installed on buildhost

Thomas Zimmermann ml at vdm-design.de
Mon Mar 15 15:58:45 UTC 2010

i tried to build an image on a minimal system today, to check which depencies 
are needed to build the image.
First thing that fails is qemu-native. It Fails during do_configure because of 
missing zlib headers.
So i tried to build zlib-native first, but that has changed nothing. After 
looking at the configure script it seems that the check just uses $QEMU_CFLAGS 
which contains only "-I. -I${SRC_DIR}" so adding -I${STAGIUNG_INCDIR_NATIVE} 
to $QEMU_CFLAGS solves that issue.

Please check the following patch, as i've no exprience with 
BBCLASSEXTEND="native" and i don't want to break qemu.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-qemu-fix-build-without-zlib-headers-installed-on-bui.patch
Type: text/x-patch
Size: 1163 bytes
Desc: not available
URL: <http://lists.openembedded.org/pipermail/openembedded-devel/attachments/20100315/db00945a/attachment-0002.bin>

More information about the Openembedded-devel mailing list