[OE-core] [PATCH 1/3] busybox: Remove PN from rdeps of PN-dev

Khem Raj raj.khem at gmail.com
Tue Feb 12 18:59:45 UTC 2019


On Tue, Feb 12, 2019 at 9:26 AM Richard Purdie
<richard.purdie at linuxfoundation.org> wrote:
>
> On Mon, 2019-02-11 at 21:47 -0800, Khem Raj wrote:
> > PN-dev is empty and causes dependency loops during SDK build
> >
> > Signed-off-by: Khem Raj <raj.khem at gmail.com>
> > ---
> >  meta/recipes-core/busybox/busybox.inc | 1 +
> >  1 file changed, 1 insertion(+)
>
> I commented on this elsewhere but for completeness, this is a
> workaround, not a fix. The problem is that the PROVIDES in target-sdk-
> provides-dummy.bb are clearly missing something.
>
> This means that the SDK tries to exclude "/bin/sh" and similar target
> dependencies from the SDK rootfs which leads to excluding busybox and
> then fails to do so. If busybox is installed, busybox-dev gets pulled
> in and the problems start.
>
> The real fix is to figure out the missing target-sdk-provides-dummy
> provides.
>
> If someone could share a way to reproduce the failure that would be a
> good start.
>

Use oe-core+bitbake ( nodisro ) settings and then
bitbake -cpopulate_sdk core-image-minimal

and you see

WARNING: core-image-minimal-1.0-r0 do_populate_sdk: Unable to install
packages. Command
'/mnt/a/yoe/build/tmp/work/sama5d27_som1_ek_sd-yoe-linux-musleabi/core-image-minimal/1.0-r0/recipe-sysroot-native/usr/bin/opkg
--volatile-cache -f
/mnt/a/yoe/build/tmp/work/sama5d27_som1_ek_sd-yoe-linux-musleabi/core-image-minimal/1.0-r0/opkg.conf
-t /mnt/a/yoe/build/tmp/work/sama5d27_som1_ek_sd-yoe-linux-musleabi/core-image-minimal/1.0-r0/temp/ipktemp/
-o /mnt/a/yoe/build/tmp/work/sama5d27_som1_ek_sd-yoe-linux-musleabi/core-image-minimal/1.0-r0/sdk/image/opt/yoe-musl-sysvinit-wayland/2.6/sysroots/cortexa5t2hf-neon-vfpv4-yoe-linux-musleabi
 --force_postinstall --prefer-arch-to-version   install libgcc-s-src
eudev-dbg update-rc.d-dev libcxx-dbg base-passwd-dev
sysvinit-inittab-dbg libz-dev modutils-initscripts-dbg initscripts-dev
opkg-utils-dbg musl-utils-dev libgcc-s-dbg init-ifupdown-dbg
packagegroup-core-standalone-sdk-target-dbg sysvinit-inittab-dev
busybox-dev gcc-runtime-dbg netbase-dbg kmod-dbg base-passwd-src
base-passwd-dbg initscripts-dbg eudev-dev sysvinit-dbg
run-postinsts-dbg target-sdk-provides-dummy-dbg base-files-dbg
musl-utils-dbg libz-dbg base-files-dev
packagegroup-core-standalone-sdk-target-dev musl-utils-src
compiler-rt-dbg dt-overlay-at91-dev busybox-dbg util-linux-dbg
kmod-dev util-linux-dev dt-overlay-at91-dbg packagegroup-core-boot-dev
sysvinit-src target-sdk-provides-dummy-dev sysvinit-dev
init-ifupdown-dev packagegroup-core-boot-dbg update-rc.d-dbg musl-src
modutils-initscripts-dev netbase-dev run-postinsts-dev' returned 1:
Collected errors:
 * Solver encountered 1 problem(s):
 * Problem 1/1:
 *   - package busybox-dev-1.29.3-r0.4.cortexa5t2hf-neon-vfpv4
requires busybox = 1.29.3-r0.4, but none of the providers can be
installed
 *
 * Solution 1:
 *   - allow deinstallation of
target-sdk-provides-dummy-1.0-r0.3.sdk-provides-dummy-target

 *   - do not ask to install a package providing target-sdk-provides-dummy-dev

 * Solution 2:
 *   - do not ask to install a package providing busybox-dev


> Cheers,
>
> Richard
>


More information about the Openembedded-core mailing list