[OE-core] kernel menuconfig broken?

Cal Sullivan california.l.sullivan at intel.com
Thu Apr 12 21:38:41 UTC 2018


If you're using a non-linux-yocto kernel you likely need to apply this 
patch to your kernel as well:

https://git.yoctoproject.org/cgit/cgit.cgi/meta-intel/tree/recipes-kernel/linux/linux-intel/0001-menuconfig-check-lxdiaglog.sh-Allow-specification-of.patch

(This is in all linux-yocto kernels, I'm only linking to meta-intel 
because I knew where it was off the top of my head)

This was sent upstream but last I looked it didn't gain any traction. I 
think Bruce resent it recently but I can't be sure.

Thanks,
Cal

On 04/12/2018 01:28 PM, Andreas Müller wrote:
> On Mon, Apr 2, 2018 at 11:57 PM, Trevor Woerner <twoerner at gmail.com> wrote:
>> On Sun 2018-04-01 @ 11:49:58 PM, Andreas Müller wrote:
>>> When running bitbake -cmenuconfig virtual/kernel I get a flood of
>>> undefined reference errors. Am I alone here?
>> Sadly, I think you might be.
>>
>>          $ bitbake virtual/kernel -c menuconfig
>>
>> works fine for me.
>>
>> I assume you're doing this for something RaspberryPi-ish?
>>
>>          Build Configuration:
>>          BB_VERSION           = "1.37.0"
>>          BUILD_SYS            = "x86_64-linux"
>>          NATIVELSBSTRING      = "opensuse-42.3"
>>          TARGET_SYS           = "arm-oe-linux-gnueabi"
>>          MACHINE              = "raspberrypi3"
>>          DISTRO               = "nodistro"
>>          DISTRO_VERSION       = "nodistro.0"
>>          TUNE_FEATURES        = "arm armv7ve vfp thumb neon vfpv4 callconvention-hard cortexa7"
>>          TARGET_FPU           = "hard"
>>          meta-raspberrypi     = "master:63e53f919089027259a513dc2cd4b140789bf1a3"
>>          meta                 = "master:4cedddb83623c79980b354642dfeaf78218ca4b7"
>>          meta-oe
>>          meta-gnome
>>          meta-python
>>          meta-networking
>>          meta-multimedia      = "master:b9d1d8718834f7287e5a65373b952cbfe9ce83fe"
>>          meta-qt5             = "master:e60e849de1158c879bd2c150fe79b207cdac031a"
>>          meta-qt5-extra       = "master:a0cf057b2f335e8d2be9180f20770773334ec209"
>>          meta-realtime        = "master:250bc6eaa47e550c1db5e2b0ebd42d86ee43650e"
>>          meta-browser         = "master:d1c902440cba26a9d1271cfb914633c68ee3791c"
> OK I found that I am not alone [1] and followed the suggestion to
> install ncurses-devel. Strange: it install ncurses-libs x86_64. Now I
> have back menuconfig but it looks horrible: All framing chars are
> displayed as '@'. If I remember correct there was such an issue long
> lime ago.
>
> However it is not beautiful but I can work with it.
>
> [1] https://github.com/crops/poky-container/issues/17
>
> Andreas



More information about the Openembedded-core mailing list