[OE-core] Multiple issues building from dizzy or master

Lauren Post Lauren.Post at freescale.com
Wed Oct 8 12:51:35 UTC 2014

Last night I moved poky back to 9/16  "0db15bb0626b16201d0767d87e91c61828a449ef" before the sstate commit and my builds are working now.  Before that I tried reverting some of the earlier patches such as (533a852eddb9a5e77a15001756f03b929a1d0a0b ) brought in on 10/6 but that did not work so something that came in last few weeks is also  causing problems.

My biggest problems is the fetch/unpack.  With tip of poky the task fetch is working but before unpack the package disappears and task unpack fails.  It happens on many random components and always in downloads I see a lock on the component but no package.  I see this with dirty and clean builds.

It will take me time to figure out which poky commit is causing the problems but my team has been waiting on these builds to proceed with testing so I can only try on one machine.  It is much harder to hit locally - I see it more readily on Jenkins build machines.

I just wanted to verify first it was a poky problem  On all 4 jenkins machines building last night none with the reverted poky back to 9/16 had the fetch/unpack issues I was seeing with the tip of dizzy branch in poky yesterday.

Lauren Post
i.MX Freescale

-----Original Message-----
From: openembedded-core-bounces at lists.openembedded.org [mailto:openembedded-core-bounces at lists.openembedded.org] On Behalf Of Lauren Post
Sent: Tuesday, October 07, 2014 10:25 AM
To: openembedded-core at lists.openembedded.org
Subject: [OE-core] Multiple issues building from dizzy or master

We've been trying for a few weeks to move all our builds to master (yesterday dizzy for poky which is the same) and been having random strange problems on multiple jenkins machines we do our daily builds on.  I talked to Otavio about it but wonder if we are missing something.    I'd appreciate any ideas.   We can build our kernel and uboot fine but when we try to build a more complex image with qt5 we have not succeeded any build since yesterday.

As of today we are now getting errors in db compilation On both locally and on Jenkins we keep getting a db compile error as of today.
./db_cxx.h:59:22: fatal error: iostream.h: No such file or directory  #include <iostream.h>
For last week we've been battling random gcc_runtime configure errors only on Jenkins machines.  

This is the configure error.
checking dynamic linker characteristics... configure: error: Link tests are not allowed after GCC_NO_EXECUTABLES.

As of yesterday morning, we are also having many unpack errors on many files that are disappearing from our downloads before unpack.  The fetch is working but then when it unpacks the package has disappeared from downloads.  I've seen this on multiple components (libx11, xproto, inputproto, util-linux).  Seems to happen more often with rm_work set but I've seen it without it set.

I'd appreciate any ideas.  The only one I can reproduce locally is the db error above but the others seem to only happen on Jenkins machines.  We have 4 different Jenkins machines all of which can't build on the master branch but have built fine for months on daisy and dora branches.  

By the way you can't set your gcc to 4.8.2 - liburcu breaks if you try to use the older compiler.  So not sure if any of the gcc runtime issues are related to the new gcc version.   Not sure if we should keep gcc 4.8.2 in dizzy if it can't be used.

Thanks for any ideas.  I've tried everything I can think of.

Lauren Post
i.MX Freescale
Openembedded-core mailing list
Openembedded-core at lists.openembedded.org

More information about the Openembedded-core mailing list