[OE-core] [PATCH 1/1] libsoup-2.4: upgrade to 2.45.92

Hongxu Jia hongxu.jia at windriver.com
Tue Mar 25 04:12:55 UTC 2014


On 03/24/2014 05:06 PM, Burton, Ross wrote:
> On 24 March 2014 07:57, Hongxu Jia <hongxu.jia at windriver.com> wrote:
>> There was an error about mips-gcc optimization while compiling
>> libsoup-2.4 2.45.3 with DEBUG_OPTIMIZATION enabled.
>>
>> The test code of libsoup-2.4 2.45.3 triggered gcc assert which located
>> in gcc/dwarf2out.c:20810:
>> ...
>> 20806       gcc_assert (prev
>> 20807                   && (CALL_P (prev)
>> 20808                       || (NONJUMP_INSN_P (prev)
>> 20809                           && GET_CODE (PATTERN (prev)) == SEQUENCE
>> 20810                           && CALL_P (XVECEXP (PATTERN (prev), 0,
>> 0)))));
>> ...
> So you've a bug in gcc and a well defined way of replicating it,
> presumably you've reported this to gcc as that's the proper fix here?

Yes, file a bug in gcc:

https://bugzilla.yoctoproject.org/show_bug.cgi?id=6034

http://gcc.gnu.org/bugzilla/show_bug.cgi?id=60643

//Hongxu

> Ross

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openembedded.org/pipermail/openembedded-core/attachments/20140325/f06ffae4/attachment-0002.html>


More information about the Openembedded-core mailing list