[bitbake-devel] Building scipy with yocto 2.2

Alejandro Enedino Hernandez Samaniego alejandr at xilinx.com
Thu Jul 26 17:10:29 UTC 2018

Hey Harini,

This email should be sent to the meta-openembedded or the oe-core list.

Also, scipy needs a math library (BLAS,LAPACK,ATLAS), and that needs to be cross compiled, you have to find  (it didn't exist back when I tried this) or create a recipe for it.


From: bitbake-devel-bounces at lists.openembedded.org [mailto:bitbake-devel-bounces at lists.openembedded.org] On Behalf Of Harini Srowa
Sent: Wednesday, July 25, 2018 3:06 AM
To: bitbake-devel at lists.openembedded.org
Subject: [bitbake-devel] Building scipy with yocto 2.2


Has anyone tried building python-scipy with yocto 2.2. Our bitbake file looks like this:

SUMMARY = "Scientific Library for Python"
SECTION = "devel/python"
HOMEPAGE = "https://pypi.python.org/pypi/scipy"

LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=d0db8f4148a3d5534cfb93be78f9287c"


SRC_URI[md5sum] = "53fa34bd3733a9a4216842b6000f7316"
SRC_URI[sha256sum] = "87ea1f11a0e9ec08c264dc64551d501fa307289460705f6fccd84cbfc7926d10"

inherit pypi setuptools distutils

RDEPENDS_${PN} += "python-core python-numpy-native python-distutils"
DEPENDS += "python-numpy-native"

RDEPENDS_${PN}_class-native += ""
BBCLASSEXTEND = "native nativesdk"

do_compile_prepend_class-target() {
    ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build

Bitbake compiles the python-scipy half way and then it is not able locate lapack/blas resources.
My build machine is x86_64 and I am building it for arm architecture 64 bit.

Let me know if anyone has come across such situation.

Thanks and regards,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openembedded.org/pipermail/bitbake-devel/attachments/20180726/8f4586ca/attachment-0002.html>

More information about the bitbake-devel mailing list