[bitbake-devel] korgoth : php + postgresql = ERROR: php-5.6.23-r0 do_configure: This autoconf log indicates errors, it looked at host include and/or library paths while determining system capabilities.

kris duff t_dufff at yahoo.ca
Mon Jul 24 20:57:59 UTC 2017


Hi,
I am trying to install PHP with postgresql in my image.
I newly upgraded my image from dizzy to korgoth. I never have been sucessfull porting php + postgresql on my last image.
So support postgresql and not mariadb, I have created a php_5.6.23.bbappend. The content of that file is below.
PACKAGECONFIG += "pgsql"
bitbake return this error :
ERROR: php-5.6.23-r0 do_configure: This autoconf log indicates errors, it looked at host include and/or library paths while determining system capabilities.Rerun configure task after fixing this.ERROR: php-5.6.23-r0 do_configure: Function failed: do_qa_configureERROR: Logfile of failure stored in: /home/krogoth/build/tmp/work/core2-64-poky-linux/php/5.6.23-r0/temp/log.do_configure.1851ERROR: Task 791 (/home/krogoth/poky/meta-openembedded/meta-oe/recipes-devtools/php/php_5.6.23.bb, do_configure) failed with exit code '1'

In config.log from the build directory, I can see the following error that trigger insane.bbclass :
warning: library search path "/usr/lib/x86_64-linux-gnu" is unsafe for cross-compilation

and looking for the configure line : I can see this : -L/usr/lib/x86_64-linux-gnu
I is very bad, but what can I do to understand where come from that -L ?  If I don't include packageconfig pgsql it works well for mariadb.
Any hints ?
Thank you a lot
Kris
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openembedded.org/pipermail/bitbake-devel/attachments/20170724/a1e2b4bd/attachment-0002.html>


More information about the bitbake-devel mailing list