[bitbake-devel] Bug with task variable overrides

Daniel Lazzari dlazzari at leapfrog.com
Wed Nov 2 22:54:31 UTC 2011

I recently tried to use per task overrides for several variables and ran into a bug. If the task name has an underscore in it, the overrides won't work properly. Here's a quick test case I did using Angstrom oe-core:

MYVAR = "apples"
MYVAR_task-my_task = "oranges"


do_my_task() {
                echo ${MYVAR}

addtask my_task before do_fetch

After running the task, the log for the task shows "apples" when it should show "oranges". My work around so far is not to use underscores in my task name, but that makes the task name look pretty unreadable. I tried to see if I could figure out a quick fix but the data_smart stuff looks pretty complicated and I don't have a lot of time to spend on this. If there's a place where you want me to file a proper bug report, just let me know.


Dan Lazzari Jr.
Firmware Engineer
dlazzari at leapfrog.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openembedded.org/pipermail/bitbake-devel/attachments/20111102/527153dd/attachment-0001.html>

More information about the bitbake-devel mailing list